2

I have a Late 2012 Macbook Pro. Both USB ports have failed, the cost of repair is not worth it. I plan to replace the entire Macbook at the end of the year. So I am looking for a cheap work around that will give at least one working and reliable USB port.

Anyway this is what is working:

Firewire port

Thunderbolt 2 port

Ethernet port

Also USB3 is working on both USB ports.

I have tried using a powered hub but this does not work. It seems that for USB1 & USB2 the ports are providing power but comms is intermittent then fails completely.

I need to try and get this up and running in a day or two using the ports that do work so I can connect USB1 & USB2 devices.

I have looked for a Firewire to USB adaptor but I think that is a no go.

There are plenty of thunderbolt 3 options but somewhat limited to expensive thunderbolt 2 docks even secondhand these are more than I would like to spend.

So any suggestions gratefully received.... Thank You!

2 Answers 2

1

The Late 2012 MacBook Pro doesn't have Thunderbolt 2, so your port listing can't be completely right.

It does however have Thunderbolt, and you can get a Thunderbolt to USB3 adapter such as this one from Kanex:

https://www.kanex.com/thunderbolt-gigabit-ethernet

Or this one from Delock:

https://www.delock.com/produkte/1095_Thunderbolt/62634/merkmale.html

Whether or not that is "cheap" for you is subjective, but it is an easy way to add a USB port to the computer.

1
  • Please leave a comment when down-voting, otherwise it is really hard to see how the answer could be improved.
    – jksoegaard
    Mar 3, 2020 at 19:06
0

I have the Kanex Thunderbolt/mini-DP to USB-A + Ethernet adapter mentioned by @jksoegaard and it works on my MacBook Pro Retina Mid-2012. Additionally I have an OWC Thunderbolt dock plugged into the adapter by a USB-A to USB-C cable to get USB-C ports. Link to the product description: https://eshop.macsales.com/item/OWC/TB4HUB5P/

I tried plugging the OWC Thunderbolt dock into my MacBook Pro with an Apple TB2-to-TB3 adapter but that causes a kernel panic every time. Even though this is a Thunderbolt hub I'm not seeing it work as a Thunderbolt hub on this computer. The hub works fine as a Thunderbolt hub on a MBP with TB3/USB-C ports so there's likely nothing wrong with the hub. I'll have to make time to contact OWC and see if there is a resolution to my problem. I posted a question about that here: MacBook Pro (Retina, Mid 2012) kernel panics after attaching Thunderbolt dock

I saw the concern was to get USB 2.0 ports but I add this detail about my TB/USB-C hub experience to my answer to show that getting USB-C is possible. Many people on this forum would suggest getting a USB-A (male) to USB-C (female) as a means to get a USB-C port but this is dangerous. The USB specifications explicitly state such an adapter would violate the USB spec, it's functionality is not defined, and has the potential to damage hardware. An adapter with opposite gender ports, USB-A (female) to USB-C (male), is defined in the spec and is safe to use. Getting USB-C ports on this MBP from 2012 was not cheap, and adding USB-A isn't exactly free either.

Another option to consider is a USB-to-Ethernet adapter. Like this one: https://www.tripplite.com/usb-device-server-4-port-keyspan-by-tripp-lite~us4a That specific product is no longer sold or supported by the manufacturer so acquiring one may be difficult, and then the drivers may not work on operating systems beyond those explicitly listed in the system requirements.

It's not likely to find a solution with anything other than Thunderbolt or Ethernet, and even then an Ethernet adapter may add an uncomfortable delay for keyboard, mouse, and other similar user input devices. FireWire is not likely to work, it's just not built for it.

In System Information the model identifier on my MBP is MacBookPro10,1. @Microkid, could you look at System Information to see what your MBP model identifier is and add that to your question? I assume it is a MacBookPro9,2. Listing the model identifier could be helpful to others with a similar problem, and for others to offer answers. I realize it's been a while since the question was posted so the problem was likely resolved by now, one way (getting the adapter suggested by jksoegaard) or another (acquiring a replacement laptop), but I post this answer regardless for the potential benefit to others.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .