2

I'm an audio producer although I have also worked as a C/C++ programmer so I'm reasonably technical!

I bought a Mac Mini about a year ago and it recently developed a fault and had to be replaced so I'm currently in the process of setting up a new Mac Mini running Catalina (10.15.3).

One of the audio programs I use is Presonus Studio One. A big part of how it's used is via third-party plug-ins which come in a variety of formats - AU, VST2, VST3, etc. The plug-ins are installed in different ways - some via a "control centre" app, some by an installer, others by drag-and-drop to the appropriate folder.

I've run into a problem with one VST3 plug-in. I dropped the plug-in into the folder (/Library/Audio/Plug-Ins/VST3). Then I ran Studio One which does a plug-in scan at startup. An error message popped up (can't remember exactly what it was) saying that the software was from an unidentified developer and couldn't be run. Ever since then, the plug-in won't load. I suspect the plug-in has been "blacklisted".

I've tried the following in order to fix the problem but so far nothing's worked:

  • Re-installing the plug-in with an installer
  • Disabling GateKeeper with: spctl --master-disable
  • Resetting GateKeeper with: spctl --reset-default

Other plug-ins are loading fine.

Now I'm stuck. Any suggestions as to what I should try next?

Cheers,

Chris

1
  • idk Presonus at all, nor have I dared Catalina yet... but Cubase has a method to re-load VSTs, like Logic has one to reload AUs. If no-one comes up with a better method, maybe grab the trial from Steinberg & see if that will give it a kick.
    – Tetsujin
    Mar 2 '20 at 11:35
0

From the man pages of spctl:

To allow Frobozz.app to run on the local system:
       spctl --add --label "My Stuff" /Applications/Frobozz.app

Labels are optional as well, it seems strange even after a master-disable that you were still unable to run the plug in.

1
  • The problem eventually resolved itself when a new version of the plug-in was updated. Dec 2 '20 at 23:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .