1

For 5 years now this bug has apparently persisted with each version of OS X. I'm now on Catalina 10.15.3 and a much newer Mac.

enter image description here

It is apparently WiFi related because disabling WiFi and using a wired connection doesn't result in the problem. It doesn't matter what I name it. This page made years ago claims to have the fix, this does not fix it at all. If I type hostname at the terminal I still get the proper name but it keeps changing the name that would appear on the network.

Is there any progress or fix on this front or will this always be a bug in Mac OS?

4
  • 2
    I’m not surprised the link you referenced wasn’t any help. The only “relevant” hint was to not have multiple network connections to the same network. Good advice because you end up having two different IPs for the same hostname; though this isn’t a deal breaker. I have my WiFi and Ethernet connected to the same network with no issues. Just out of curiosity, what router do you have? – Allan Feb 27 '20 at 16:02
  • 1
    I think the main issue is at work so I don't know, but the WiFi guest network is on a completely different network than our internal wired network. The problem seems WiFi centric. – Sephethus Feb 28 '20 at 21:21
  • We need details. Where exactly is this happening, work or home? Please describe the network(s) that you’re connecting to (i.e. guest network at work, separate from wired network, IP address, etc.). I think you’re seeing the message, thinking you have this “bug” when this time it’s legit. They didn’t code that error message as a mistake. – Allan Feb 29 '20 at 1:05
  • Happens at home (Netgear Orbi) and at work, A Cisco WiFi access point of some sort, not sure since I don't have access to the admin console. Does not happen if I disable WiFi and use a USB wired connection. – Sephethus Mar 1 '20 at 5:24
1
  1. Open a terminal.

  2. Type the following command to change the primary hostname of your Mac:

This is your fully qualified hostname, for example, myMac.domain.com

 sudo scutil --set HostName <new host name>
  1. Type the following command to change the Bonjour hostname of your Mac:

This is the name usable on the local network, for example myMac.local.

sudo scutil --set LocalHostName <new host name>
  1. If you also want to change the computer name, type the following command:

This is the user-friendly computer name you see in Finder, for example myMac.

 sudo scutil --set ComputerName <new name>
  1. Flush the DNS cache by typing:

    dscacheutil -flushcache
    
  2. Restart your Mac

2
  • 5
    Yup. Brute force name changing will set the names correctly, but it doesn't solve the underlying problem, which may crop up again. I think it is some problem with MDNSResponder. – IconDaemon Feb 27 '20 at 14:41
  • He's right, I've tried all this, it doesn't work and the problem simply returns. – Sephethus Feb 28 '20 at 21:19
1

Had this issue for a long time with our 500+ Macs. Our setup was the Meraki Wifi with about 60 AP's on 3 floors and all dhcp/routing handled by the Fortigate firewalls.

Users were floating about the office plugging into both wifi and ethernet simultaneously. Tried pretty much everything from flattening the network, reducing VLANS, reducing the scope so that there wasn't an abundance of unused IP addresses available, and a lot of onboard Mac configuration trials with the hostname and static IP trials. Still the overall feeling is that it had to be related to the MDNSResponder, maybe being too slow to switch networks and update DNS. But finally it was a simple change for us. Our Network vendors (we had actually 2 working on the same issue for us) directed us to try Disabling Bonjour Forwarding.

We went into the Meraki Console and Disabled Bonjour Forwarding. Instant fix. I hope the picture below shows it, but its basically

Console > Wireless > SSIDS > Edit the SSID in question (we did all of them) then scroll down like in the picture to "Disable Bonjour Forwarding".

Hope that helps.

Disable Bonjour Forwarding - Meraki

3
  • Apple will literally never address bugs, ever. They'll deny them or ignore them but never address them. I can't change to bridge mode. It's not workable. – Sephethus Nov 12 '20 at 21:04
  • I'd say they're reluctant to "address bugs" that are actually problems in your own network setup, because if they DO, and introduce strange work-arounds into their networking code - the situation will be much worse for all the people whose network is set up correctly... I'm suffering from the same issue at home, and I KNOW it is a problem of my stupid router (forced down my throat by my cable Internet supplier). – Motti Shneor Feb 21 at 16:56
  • BTW, generally speaking, what's "Bonjour forwarding" and where would you go to disable it (if that's at all possible) on home access-points/routers/modems ? my home router is some junk I am forced to use by the Internet supplier, and I haven't found any such configuration in its miserable UI. Any ideas? I also have an old Apple TimeCapsule Router connected via ethernet. Can it be the cause? – Motti Shneor Feb 21 at 17:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .