0

so I am assuming the following problems are all connected as they all appeared more or less at the same time, so please allow me to quickly recap: I have a Macbook mid 2012, 10.13.6 High Sierra.

Half a year ago my Macbook wouldn't start ("prohibitory"-signal). Went to repair shop. Told me it was the internal hard drive cable, which after some time can get too hot, apparently a common issue for this model. Changed it, everything runs fine again.

Some months later (this week): Macbook is starting to behave slowly, gets stuck, with a spinning wait cursor which I can still move but it would not react when clicking on stuff. Then, after a while it would allow me to do something again, before going back into spinning wait cursor. Silly me was thinking, mh, let's restart, but hey, there is anyhow this system update waiting! So in one moment of control, I clicked to update: it downloaded and restarted. After restarting the update would be stuck after like half a centimeter progress. I waited more than half a hour. No progress, so I forced a shutdown. After restart, new problem: it would simply freeze when I enter my login information and not start the system.

Again, I went to the repair shop. Eventually he would try again replacing the internal hard drive cable. That solved the issue again. I told him that the one cable I got recently was not old. He said, it's because FileVault can cause this which he recommended me to deactivate. Back at home I try exactly that.

Problem 1: Filevault decryption is stuck and wouldn't progress, it always says "two hours remaining". Also after "restart" (see 2.), it stays the same saying two hours remaining.

Problem 2: A clean restart is impossible. When trying to shut down or restart, it would stay forever at this black screen where you only see this rotating loading icon. So, I always have to force shutdown, then start again.

Problem 3: Another thing which is new, that suddenly I cannot login to my iCloud sometimes (weirdly it worked in the Appstore, but never in Mail)

Problem 4: also appeared just now. When I am in the university using their Wlan, I have to re-enter my login information every time after the macbook was in standby mode. This seems unrelated, but it never happened before.

Problem 5: Maybe also unrelated, but only occurred now, so probably not. A program (ableton) would suddenly not start anymore and simply say that it cannot be opened. I also cannot find it under applications anymore which never happened before.

Disk Utility says it could not deactivate starting volume but found errors that would have to be repaired by disk utility in recovery mode. Other than that it said (excerpt):

"

...

Checking the APFS suberblock.

Checking the object map.

warning: omap (oid 0x9a2c3): invalid om_flags (0x4)

error: om: btn: invalid o_oid (0x8f422)

Object map is invalid.

The volume /dev/rdisk1s1 could not be verified completely.

...

"

One thing that kinda bothers me is, I am still not sure if the beforementioned update was installed after all. In the app store it does not show up under "recently installed updates", it is simply gone.

I will probably try to do as disk utility says, and repair from recovery mode, however I am a bit hesitant as I am new to Macbooks, and not familiar with these recovery routines, what it entails, whether data loss is possible etc. So before I wanted to ask if it's maybe a known issue.

Last thing: I have a TimeMachine backup basically from one day before this whole mess (before the thing with the update happened). Does this help? I feel the issue is somehow deeper.

Any ideas? Thanks in advance

1

I think you have received some bad advice from the repair shop, unfortunately.

It is correct that the 13" MacBook Pro 2012 model have issues with the internal hard drive cable. It hasn't got anything to do with overheating though. It is also incorrect that FileVault have anything at all to do with the cable problem.

The cable problems comes from the fact that the original cable was designed slightly too thin, while the inside of the casing is not completely smooth. Over time the friction between the two can cause the cable to fail.

You can replace the cable with another cable of the same type, which you indicate the repair shop did. The problem will just occur again.

The permanent way to fix it is to replace the cable with a new type of cable that is slightly thicker. This is what Apple does if you take the computer to them. Another way to fix it is simply to add a piece of smooth tape to the case where the cable runs, so that friction is reduced.

Tape in case

You can find detailed instructions on how to apply the tape here:

https://beetstech.com/blog/prevent-a1278-mid-2012-hard-drive-cable-failure

You currently have issues with the file system on disk. This could be caused by problems with that cable - but it could also be the disk itself failing.

I would recommend fixing the cable issue as described above, and then restoring the known good backup you have. Make sure to do disk checks to make sure the disk is OK - if you get disk errors again, it's reasonable to assume the disk is broken and needs replacement.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .