1

My Mac mini is currently is version 10.12.6. Xcode requires "version 10.14.4 or laterV. However, when I check for available updates for my OS, there are none

5
3

You can get earlier versions of Xcode from here:

https://developer.apple.com/download/more/?=xcode

This may be an option if you can't upgrade the OS.

1

New major versions (like macOS Catalina) need to be downloaded from the Mac App Store. They may not show up in System Preferences (nowadays they do, but AFAIR not in 10.12).

Depending on the model of Mac you have, you may not be able to upgrade to 10.14 though. Look for your model in https://everymac.com/systems/apple/mac_mini/index-macmini.html and check the max OS version listed there.


Your model (https://everymac.com/systems/apple/mac_mini/specs/mac-mini-core-i7-3.0-late-2014-specs.html) can be upgraded to run macOS Catalina. Just download and install it from the Mac App Store.

0
-1

If you can't upgrade to Catalina you can load an earlier version of XCode. The last system I could upgrade to is 10.13.6. The version of Xcode I'm running is 10.1. You should be able to find this version.

Not the answer you're looking for? Browse other questions tagged .