2

Approximately twenty hours ago, I shut down my MacBook Pro and got on a plane. At home, everything was working. Now, at my sister’s house, I cannot get anything in Safari nor by ping.

Ping gets “no route to host” for any name or IP address, even when I ping the IP address of the DNS server that successfully resolved the other host names.

To make sure the DNS wasn’t cached, I rebooted, and tried a hostname I knew hadn’t been used in months. The name was resolved, but still, “no route to host.”

It’s not my sister’s router, because I get the same thing when I switch to my iPhone’s hotspot.

It’s not any of the remote hosts, because they are working for the iPad and for my sister.

When I use Fing (a network scanner) on the iPad to examine the network, I see that everything is on 10.0.0.x including a Cisco router.

My iPad and iPhone and her Android and Windows are working fine on the same SSID.

???

Could it be that TCP on the laptop somehow broke in transit while UDP still works?

UPDATE: Totally weird. ifconfig get packet en1 had absolutely no output. tcpdump -s 500 -v -I en1 also did nothing for about a minute, even though I tried a ping in another window (which also did nothing). But then tcpdump started rolling, and it was fairly plain that both sides were trying to do lots of IPv6. Going back to the settings, it had changed itself back to manual. I kept changing it to DHCP, but every time I did anything, it changed back to manual. Eventually, without knowing what I had done differently, it stayed on manual and then everything worked. And the router is definitely 10.0.0.1. SMH.

  • In your network settings, is it set for DHCP? – Allan Feb 25 at 7:48
  • At home, I use manual settings, but I changed the MacBook to DHCP as soon as I got here. But the phone and iPad are still static, and they work. They are also set to 192.168.1.x which makes me puzzled why I can only find 10.0.0.x in a WiFi scan. – WGroleau Feb 25 at 16:38
  • The phone would use the cellular connection if it couldn’t browse via WiFi. Same with the iPad if it too is cellular or tethered to the phone. Can you confirm and post the IPs of each? As for the Mac, let’s get the DHCP details... issue the command ipconfig getpacket en0 and post the output – Allan Feb 25 at 17:12
  • It would be en1 for WiFi. Also, unless Apple has recently fixed a design error, when an iPhone has a WiFi connection to a router, it will not use cell data, even if the router has no internet. But the router obviously does have internet, as all devices, including those without cell capability, are able to “surf” (except the MacBook, which can still resolve DNS). If it did use cell data, that doesn’t help, as the MacBook’s behavior is the same whether on sister’s Comcast WiFi or my AT&T hotspot. – WGroleau Feb 25 at 18:17
  • 1
    Simply add ipconfig getpacket en1 or I will write an essay why the TCP part of Apple's IP-stack is much more sensitive to cosmic rays during flights than the UDP part (and therefore should be treated with a special massage action after being on firm ground again). – klanomath Feb 25 at 18:39
1

This is more of a guess than an answer, but perhaps having a static 192.168.1.x connect to a 10.0.0.1 confused everything, including having it refuse to accept being set to DHCP. But how it was able to serve DNS in spite of everything else failing is still a puzzle. Maybe the DNS worked through IPv6.

The reason the iPhone worked (apparently) is that it was on DHCP (even though I know I put all my devices on static 192.168.1.x addresses.

| improve this answer | |
  • 1
    So my answer was correct. You were not set to "Using DHCP" and getting the machine set to that would resolve the issue. I have added an additional suggestion in my answer. – Jimmy Mooney Feb 26 at 20:42
1

If DNS is served from your router, then DNS working means the physical transport from the host to the router is set.

If things the router needs to route fail from the host, and you change nothing on the host, and then the router starts routing, then that's a pretty large smoking gun pointing you at a router issue.

  1. What do the router logs show?
  2. Does the router / switch have port-fast or BDPU or spanning tree configuration you can safely change to test if that's causing the blockage?

Unless your Mac has containers, virtual machines, multiple synthetic / virtual network interfaces, or is acting like a router, there's not much chance macOS is causing or even related to the problem. To test this you could boot to recovery and use the Utilities menu to run your tests with the same router, same hardware and a thinned macOS runtime / OS.

| improve this answer | |
  • Ah, but notice that I said I could not ping the DNS server that had resolved the address of other sites. Using for DNS the router, and 1.1.1.1, and 8.8.8.8. – WGroleau Feb 26 at 1:49
  • Set up your router as DNS server or you're totally in the dark, @WGroleau - with your setup you'll need Wireshark and a network engineer to analyze things unless I'm missing something else easy like you have LittleSnitch firewall or equivalent working as configured. It's still a router issue if some traffic passes but not all does. – bmike Feb 26 at 1:51
  • I also said it’s not my router. Over the years, my DNS servers have been the router, assigned by the router, a paid service, 8.8.8.8, 1.1.1.1, and my own local copy of BIND 9. None of them have ever given me any trouble. This incident was not the DNS server’s fault. – WGroleau Feb 26 at 2:06
  • As I've said - Wireshark or change the router. Sorry it's not the answer you seek. I'm the only one to give you a +1 so maybe another answer will arrive? In my experience, you've pretty much already isolated this to the router. – bmike Feb 26 at 2:16
  • I've pretty much isolated it to the MacBook, not the router, as my update indicates. – WGroleau Feb 26 at 2:21
1

Edit: based on your edit above, I recommend following the steps below, but removing the wireless connection and re-adding it before going to "Advanced" settings. I've broken up step 1 into three parts, below.

  1. On your Mac go to System Preferences > Network

    a. Click your Wireless Connection > Minus Symbol (-)

    b. Click the Plus Symbol (+) and re-add the wireless connection

    b. Click your (new) Wireless Connection > Advanced

  2. On the TCP/IP tab ensure "Using DHCP" is selected, Configure IPv6 is set to "Automatically".

  3. On the DNS tab, remove any entries that do not appear in grey text. Those would be overrides you've added at some point (knowingly or not)

  4. On the Proxies tab, uncheck any checked boxes.

  5. On the Hardware tab, make sure "Configure:" is set to "Automatically"

  6. Ignore the other tabs.

  7. Click the OK button. Reboot the machine.

If this does not resolve your issue, look to the router config for some kind of MAC or device-type whitelisting settings in the admin.

Also - compare your DNS and IP Address, and router address information to that of the iPad or phone and ensure it is the same.

| improve this answer | |
  • I’ve never used any proxies, and did the rest of that (most of which was plainly indicated in the question body). – WGroleau Feb 25 at 22:11
  • 1
    None of those troubleshooting steps were indicated in your original question other than "rebooted". Does your sister have children? Is it possible she has some kind of device like a Disney Circle which has quarantined your laptop? – Jimmy Mooney Feb 25 at 22:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .