0

I'm trying to create a project, which will run on the xCODE's simulator, not on an iPhone. Right after the project is created, there are multiple errors. The first one is:

Failed to create provisioning profile. There are no devices registered in your account on the developer website. Plug in and select a device to have Xcode register it.

I found many similar issues, but the given solutions didn't work in my case, or the issues where slightly different than mine, so I couldn't use them.

If there's any information needed for anyone to help, tell me and I'll provide it.

enter image description here

1
  • If you’re still looking for more answers, listing sw_vers and your exact Xcode build and version might help another person to answer. I think the existing answers are good so no worries about an edit unless you’re still stuck here. – bmike Jul 4 '20 at 18:34
1

The solution for this error is emptying the field at the Code Signing Identity at Build Settings.

enter image description here

I thought it didn't help since there are still multiple errors. I now realize that those errors are not related to the one this question deals with.

1
  • I have these things, and still got the same error, are u solve it? – Oliver D Feb 17 at 21:12
0

Xcode is named Xcode - not xCODE. It is not an emulator.

With that out of the way, the solution to your problem is - as it is also stated in your screenshot - to plug in your iOS device to the computer in order to get it registered with Apple's system. It is required before you can create a meaningful provisioning profile.

Note that you do not have to do any of the above if you only want to run your program in the simulator. In that case, select to build for one of the installed simulator in the Xcode top bar.

In case you haven't got an iOS device to add to your provisioning profile, and you want to only use the simulator, you can simply forego signing completely. You can do that by following the answer to this SO question:

https://stackoverflow.com/questions/31039513/how-can-i-skip-code-signing-for-development-builds-in-xcode/54296008#54296008

Essentially it means ensuring that the "Code Signing Identity" field in your build setting is set to nothing at all (empty).

9
  • Good to see focus on the issue. The logo for that software is xCODE on VMware. I never said it was an emulator. It has an emulator (or a simulator), to which I refered as the xCODE emulator. It is the xCODE emulator. – random Feb 22 '20 at 20:17
  • As I wrote in the question: I don't intend on using an iOS device to plug it to the computer. I wish to use the emulator. There's no device to plug. – random Feb 22 '20 at 20:18
  • An iOS simulator is selected by default. In my case it is iPhone 11 Pro Max. – random Feb 22 '20 at 20:23
  • 1
    You're just confusing terminology here. There's no emulator. It is not an emulator. It does not contain an emulator. It hasn't got an emulator. So - no emulator, it's a simulator (it's not the same thing). The name is not xCODE - it is Xcode. There's no logo for Xcode that says xCODE. – jksoegaard Feb 22 '20 at 21:02
  • As far as I understand you - you haven't got a Mac, and you haven't got an iOS device. However you want to build something and run it in the simulator - is that correct? If that is the case, you simply need to disable code signing completely. – jksoegaard Feb 22 '20 at 21:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .