0

I am having a strange issue with my Mid 2010 27 inch iMac - I get the chime, I can get into recovery partitions and into installer USBs no problem...but I can't seem to get a single install working. It'll just reboot a minute or two into installation. I can get into the desktop of an old Lion drive - but I get the "your computer needs to restart" error. It also failed halfway through internet recovery CommandR

I've already tried SMC and NVRAM resets of course.

Here is a picture of the kernel error I am getting. Any help with this would be appreciated.

Original image: https://imgur.com/maSoJIE

Edit: attempt to make the original more legible [not hugely successful]

enter image description here

  • What system versions have you tried? I have the same iMac computer. – jmh Feb 22 at 21:56
  • You cannot install MacOS on this computer. MacOS only runs on Motorola 68k and PowerPC CPUs, but this computer has an Intel CPU. – Jörg W Mittag Feb 23 at 0:14
  • Try Apple Hardware Test to see if there’s anything going on with your system. However based on past experience, it’s either the GPU or memory. Memory is cheap to test, so I’d start there. – Allan Feb 23 at 1:02
  • That was a typo, @JörgWMittag PowerPC Macs didn’t come with Internet a Recovery or we’re capable of running Lion. – Allan Feb 23 at 1:06
  • OP is trying to install macOS, not MacOS. His machine can run up to 10.13.6 High Sierra but cannot run systems beyond that. – jmh Feb 23 at 1:18
1

Firstly: check the disk.

A ten-year-old Mac is a likely candidate for a failed hard drive. Use Disk Utility to check the drive.

Secondly: check the rest of the hardware.

If you have a bootable system on an external USB drive, which you know boots on another Mac, see if that will work. If it doesn't, then the problem is likely a hardware fault.

| improve this answer | |
  • I have tried on multiple external drives. I have 120/240/480GB solid states and ive tried on all of them - and a few HDD as well. I cannot get ANY mac operating system to run on this iMac. I also have multiple different RAM sticks (10600 and 12800) I have tried multiple ram configurations with different sticks and that does not seem to be the issue. – tylerjones9215 Feb 23 at 4:17
  • Then it's likely a hardware fault. Either see if there's a local Apple technician who will have a look at it, or call it a day. – benwiggy Feb 23 at 9:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .