0

There are a lot of people that have a problem verifying mail clients and there are lots of solutions that may or may not work.

I've seen that I have this problem every time my mail client (Catalina) tries to access a Hotmail account from a physical location that it is not used to. I get an email notifying me about a suspicious activity, which I mark as safe, but the mail still cannot verify the account (password is certainly correct). The only solution until now was to completely remove and add the account, but I cannot do this every single time I travel. It is getting ridiculous.

I understand that this is a security feature for my own benefit, but most of the time lately I don't have access to the mails. Is there any way to disable this feature? Or some other workaround?

  • "...tries to access a Hotmail account from a physical location that it is not used to." What exactly does this mean? Other networks? Different countries? – IconDaemon Feb 21 at 17:54
  • what I mean is different countries, therefore also different networks - the system recognises that the sign-in is unusual because it is from another part of the world, but how do you avoid it if you travel a lot? – uuu Feb 21 at 18:09
  • Which system recognizes the unusual signin? – IconDaemon Feb 21 at 18:31
  • I get an email from Microsoft, but that is just a notification about unusual activity and prompts you to check it out (I do and I even mark that 'it was me'). At the same time (probably also for the same reason) the Mail client asks for a password to access the account (which should be done automatically), but after I put it in, it cannot verify it. – uuu Feb 21 at 18:42
1

Per Microsoft:

Microsoft prioritizes account security and works to prevent people from signing in without your permission. When we notice a sign-in attempt from a new location or device, we help protect the account by sending you an email message and an SMS alert. If your phone number or email changes, it's important to promptly update the security contact info on the Security basics page so we can work with you to keep your account secure and active.

If you sign in to your account while traveling or if you install a new app that signs in with your account, you may get an alert. We just need you to provide a security code so we know it was you, and that your account is safe.

I added the bold part. It appears that MS notices the IP or access location is new or different than usual and requires the additional security login measures.

Catalina does not control your email access, it simply sends the credentials to the mail server. It's possible that it takes time for MS's mail servers to validate your response to their security challenge.

I also have a Hotmail account and I use Spark as my email client on Catalina. This happens to me when I travel but I find when I wait 10-15 min I can login again. Strangely, this doesn't happen to my Yahoo or gMail accounts, only Hotmail (and Outlook but it's the same system).

|improve this answer|||||
  • I understand the part from MS - after getting the notification about unusual activity, I go to the activity page and mark it as 'me'. This should indicate that I am aware what is happening and that everything is ok. Mail client (the built-in Mac email client) then fails to validate the password. This time it took a full day for the validation to come through, which is ridiculous. I'd hate to have to switch clients again, so I am trying to find a solution. – uuu Feb 22 at 10:51
  • I've never had to wait a full day but several hours is normal. I moved away from Hotmail as one of my primary email accounts. I now use Yahoo as my main account and don't have any of these problems anymore. – fsb Feb 22 at 15:17
0

I think that is not Apple's fault, so you need to contact hotmail for a solution because the mail client works as expected.

The mail provider send you such mails in most cases in order to notify about this kind of suspicious logins, so may they are also able to turn it off.

[EDIT] Maybe the web client offers some settings for disabling such notifications.

|improve this answer|||||
  • That is the thing - I've noticed it only on Mac Mail... Thunderbird works with no issues – uuu Feb 21 at 18:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .