1

I recently formatted my Mac Pro and I copied all the files to external drive, I didn’t use TM. After creating a new account on a new OS I can’t open the files, because the old user can’t be located. I can’t copy the files to the new account. I need to access my logic files but I can’t find a solution. I tried making a new TM and editing the contents and replacing it with my old files, but editing the TM is prohibited. Is there a way I can restore a Mac using a copied drive or a possibility that I can custom make a TM drive with the files. Or If there is a solution where I use a windows machine to open the folders. I need to get to these files

  • If these were your files to begin with then you should be able to access them, unless you are using a different User Name now then when you backed them up. Have you tried taking ownership of them? – user3439894 Feb 20 at 23:22
3

Even if you have the same username on a different instance of macOS (it could be the same computer), the OS doesn't see the two as being the same.

What you need to do is take ownership of the files.

Using Finder

You can do this in finder by using "Get Info" when selecting a file or folder. In the example below, I'm selecting an entire folder to take ownership of.

  • Press ⌘ CommandI for "Get info"
  • Unlock the "Sharing and Permissions" pane
  • Add your name by clicking the plus (+) symbol
  • Then select "Make username (Me)" the owner

enter image description here

Apple has an excellent support document detailing these steps.

Using Terminal

It's actually much easier (IMO) to do this via Terminal Just issue the following command (you'll need to enter your password at the prompt)

$ sudo chown -R <YourUserName> /path/to/file  

Where...

  • -R = recursively; it will take ownership of it and it's sub-folders (if any)
  • <YourUserName> is your login name. If you're not sure issue the command whoami at the prompt
  • /path/to/file is the full path of the file or directory you want to take ownership of
|improve this answer|||||
  • Doesn't see the two as being the same unless the UID is the same. That's what matters, not the text representing the user name. – Marc Wilson Feb 21 at 16:19
  • incorrect, @MarcWilson . It’s the UUID of the user, not username or user ID (UID). – Allan Feb 21 at 18:09
  • Typo on my part. You are of course correct. – Marc Wilson Feb 21 at 20:32
0

You can "ignore ownership" on an external drive:

  1. Select the external drive
  2. Do "Get Info" (right click and choose it, or command-I)
  3. At the bottom of the info window, click the lock, and enter your password
  4. Check the "Ignore ownership on this volume" box
|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .