3

Turns out, everything i put inside any folder in my mac, is being uploaded to the cloud, showing me the cloud icon, and files are not available when i need them.(which by itself is a strange UX)

To stop this, i went into iCloud Drive ->options->, and uncheck the Documents and Desktop Folders.

Then i get a mesage saying that all my files in Desktop/Documents folder will disappear from my mac, and will be available in iCloud if i uncheck this box.

I want back my files on my mac. I don't want to go and look for them in iCloud now, but keep my folders structure as it is, with my files not in icloud, but right where i put them in first place. (download all of them)

How to cancel this hostage UX, and get my files where they belong, without removing them from my mac first(as the massage says) ?

2

.. and files are not available when i need them ..

macOS < 10.15:

System Preferences → iCloud → iCloud Drive options → Uncheck Optimise Storage.

macOS 10.15+:

System Preferences → Apple ID → iCloud Drive options → Uncheck Optimise Storage.

All files will be found locally, always, as well as on iCloud.

For the second part,

What may seem counterintuitive is that your files are still stored in the iCloud ( which is perhaps why you thought you lost them).

To retrieve your files, you should open Finder and navigate to iCloud Drive, and then to the Documents folder within iCloud Drive. You should then manually transfer or copy the files from that directory to the local Documents directory on your computer. You should then do that same with your Desktop folder.

6
  • Thanks - as for the second part of your answer - I can't believe that a company in this scale do that - to go over tens of files and copy them from iCloud into my mac, one by one, and re-organize them again ? Who asked Apple to upload all my files ? and why i can't get them all back with a push of a button? this is why i pay so much for extra iCloud space ?
    – hkrlys
    Feb 20 '20 at 21:02
  • btw- its just stuck, it try to download everything and its not moving. I HAVE NO ACCESS TO MY FILES ! Apple you are losing it !!!!
    – hkrlys
    Feb 20 '20 at 21:06
  • @hkrlys they are just two folders, just copy, paste, delete
    – anki
    Feb 20 '20 at 21:10
  • 1
    @hkrlys you can get them all back if you uncheck the optimize button then drag them back. You don't have to do anything else.
    – Ezekiel
    Feb 21 '20 at 1:08
  • 2
    @hkrlys The answer to "who asked Apple to upload all my files?" is "you did". That checkbox is not selected by default. Feb 21 '20 at 16:23
1

You should uncheck the Optimize Storage button and wait for your files to finish downloading. Restart your computer if you don't see any progress right away.

When they've downloaded, you'll be able to move them instantly.

2
  • "move them instantly" what does it means? how do i do that? if i uncheck that box, they will disappear from my mac, whats then ?
    – hkrlys
    Feb 21 '20 at 7:17
  • @hkrlys they will disappear from local desktop and documents, BUT since they are in iCloud( and downloaded already since optimise is off), you can copy paste.
    – anki
    Feb 21 '20 at 8:33
0

I made a same mistake I turned on iCloud and then turn it off. I thought my files are gone because they were not visible in recovery software. Then I put the name of file to finder search and it was in iCloud version of Documents folder completely fine. But for some reason I did not see that folder in finder or my user documents.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .