0

For some time now (maybe after some Catalina update) I have had problems with some keys on my MacBook Air 2014. The keys not working are the right shift and function keys F1-F9.

I am sure it is not a mechanical problem since they work or fail together. I have not experienced any other problems. I have tried to reset the SMC and the NVRAM but whatever they do, it is only temporary. When I booted Ubuntu from a USB drive, it scared the computer into working a few minutes but now the keys are dead again. I'm thinking about downgrading to some earlier macOS, but I don't know if that will work.

Do you have any suggestions or solutions to this problem?

Update 1: The problem persists in safe mode.
Update 2: There is no problem with external keyboards (At least the right shift works).
Update 3: Other people also have this problem:

  1. https://discussions.apple.com/thread/2805492
  2. https://discussions.apple.com/thread/2356256
  3. https://www.mac-forums.com/forums/apple-notebooks/170660-f1-f9-keys-shift.html
  4. https://www.mac-forums.com/forums/apple-notebooks/271214-shift-key.html

Update 4: Maybe it was mechanical after all. I opened the laptop and poked around a bit, and now it works! If this effect is lasting I will post it as an answer.

  • Did you try to see the issue in SafeMode too? check whether it replicates similar kind of issue in Safe Mode or not. – Udhy Feb 20 at 16:56
  • @Udhy The problem replicates in Safe Mode. – Mankka Feb 20 at 18:31
  • if you want to confirm it was Catalina and also see if an earlier version will work, install High Sierra or Mojave onto an external USB drive (a 64GB flash will work) and boot from that. If the problem goes away, you have your answer and then can do the full downgrade. – Allan Feb 21 at 13:21

You must log in to answer this question.

Browse other questions tagged .