1

When I try to move photos off my iPhone 7 on Windows 10 it suddenly stops saying "Error Moving File or Folder: A Device attached to the system is not functioning."

The error occurs on only some specific pictures or videos.

How can I get these photos/videos off my phone? I want really to keep them.

This is what I have tried:

  • I have connected the phone via USB/lightning cable.
  • I have tried using various different cables as well as different USB ports.
  • I have tried powering the phone off and on again.
  • I have tried hard reseting the phone by holding in the volume and power buttons.

The photos and videos work just fine if I view them on the phone itself. I have tried sending the videos and images to myself using Signal. Then importing them on Signal on the PC. However, Signal seems to compress the files (lossy) so this is not really a viable option.

I would like to avoid uploading them to Google Drive or similar and then importing them from there because I do not want to share my photos, etc. with Google or any other cloud provider.

I have captured a video of what happens here: Screen Recording

One more thing to add: I bought a completely new original Apple ligning-to-USB cable just to make sure it was not the cable.

4
  • 1
    What happens if you just try to copy rather than move. Move would require delete permissions on the iPhone, copy would not.
    – Tetsujin
    Feb 20 '20 at 16:14
  • 1
    And you can set iTunes to copy all pictures to the local drive as well. Have you tried that? Feb 20 '20 at 16:31
  • @Tetsujin: Same error comes when I select COPY instead of MOVE. Feb 21 '20 at 10:19
  • @SteveChambers I was not able to find any way to copy pictures from iTunes to local drive. There is an option to sync photos. But that seems to be for sync'ing photos FROM PC to iphone. Feb 21 '20 at 10:20
2

On your iOS device,

Go to Settings > Photos and scroll down,

Find the “Transfer to Mac or PC” section.

And select “Keep Originals”.

It will resolve your current issue.

4
  • This does seem to fix it for videos! However, the photos now all appear as .HIEC files and not JPEG files. Appearently, I cannot open these .HEIC files. What are those? And how to obtain the actual JPEGs? Feb 20 '20 at 18:40
  • Appearently, the .MOV files imported this way does not play in VLC :-/ Feb 20 '20 at 18:48
  • OK. So as I understand this feature, Automatic means that the iPhone itself converts the photos and videos from the internal .HEIC format to JPEG format "on the fly" when importing them. Is that correct? Does this mean that the problem I have with failing transfers is due to this conversion failing somehow? Is there no way to fix this - so the conversion does not fail? Because with HEIC format I will end up with a bunch of files I cannot open. Feb 20 '20 at 19:10
  • I would really like to mark this as resolved - however, it does not quite seem to be resolved. Doing as suggested here does not allow me to obtain actual usable photos (that are clearly on the device) Feb 25 '20 at 14:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .