I recently upgraded to Catalina(which I regret now). I have been facing lot of weird issues after upgrading one of which being not able to share the screen on Google Hangout Meet. I followed a few of the approaches mentioned in other forums.

The fix was simple where I have to go the System Preferences > Security and Privacy > Screen Recording and make sure Google Chrome is checked.

The issue for me, though, is that I am not seeing "Google Chrome" on the list when I go to the Screen Recording section and I have no idea how to make Google Chrome seen on the list. Can anyone help with this?


Chrome must first ask for the access. At that time it will show up here unchecked, unless you selected "allow" at the time that it asked.

As @ankii mentioned tccutil will allow you to reset your permissions, but you will require the bundle id of the app in question.

To get the bundle id

% osascript -e 'id of app "Google Chrome"'

From there you can reset Chrome's permissions using tccutil

Reset permissions

% tccutil reset ALL com.google.Chrome

At this point, if Chrome wants to do anything that would require explicit permission from you, it will have to ask again. It has the permissions as though you had installed it for the first time.

  • I tried this but maybe I did something wrong that's why it didn't work for me. However, I found another way to do this. launchctl list | grep -i chrome tccutil reset All com.google.Chrome This worked like a charm for me. Thanks for pointing me towards the right direction. – Sulove Bista Feb 21 '20 at 5:42
  • @SuloveBista You need to quit and re-open Google Chrome after running tccutil. That's probably why this answer didn't work for you. – Nic Mar 13 '20 at 0:07

Visit https://meet.google.com/

Start a meeting, then cast your screen

Then you'll prompt the permission window.

enter image description here

After that, it'll appear in the Screen Recording section.

enter image description here


I had this issue where Google Chrome was not showing up on the list at all. Turns out that there was a pending request from another app that was in the background, still waiting for me to "Open System Preferences" or "Deny". Once I cleared that out, the system prompt for Google Chrome showed up.

  • Thanks a lot! Holy reboot solved the problem. And during the reboot process I saw another app's dialog for screen recording permissions, just as you said. – Sasha Aug 3 '20 at 11:54

I had this issue, where "Cast..." was not correctly asking for the "Screen Recording" permission. Rebooting, tccutil, and other tricks did not work for me - instead, I installed a Screen Recorder extension which asked for the permission. Once it was granted, "Cast..." worked fine and I was able to uninstall the extension.

Edit - I filed a bug in Chromium's bug tracker, and it looks like it wasn't correctly requesting the permission. A fix has been committed so should be fixed soon!

  • Thanks, works for me. – Tran Triet Jan 29 at 13:27

For if you find this problem through Google, I found another solution:

Make sure you start the application from finder and not a third party program.

Applications started showing up in System Preferences > Security and Privacy > Screen Recording again but only when I used finder to start the application

10.15.7 Catalina

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .