80

In the bottom right corner of my Macbook Pro (running MacOS 10.15.3 Catalina with a second screen connected as main), sometimes, there is a region (invisible) where I just can't move the cursor to. I need to restart the MacBook Pro to let me access the region with my mouse cursor.

The cursor just won't pass this region, just as if the screen has ended there. I have added a screenshot below and drawn the region.

I read about applications that might behave weird and cause such an issue, but the problem persists even when all apps are closed.

What could this be?

Are there any known issues? Or yet better, known solutions? ...

Update 1:

  • I have appended a screenshot of my arrangement and drawn a yellow box of the area which is not accessible.

Update 2:

  • The cursor is blocked from reaching the region in the third screenshot (I cannot reach the Files folder for example).

Update 3:

  • Today (2020/05/25, using Mac OS 10.15.4), the problem re-occured, but the non-accessible area has changed to the top-left, with the available height only being as much as the system menu and a width of 90%. (For example, I have a window in full height/width and I can no longer move the mouse cursor to the 'minimize' or 'close' window buttons).

Update 4:

  • 2020/10/30, (using macOS 10.15.7) I returned my 15" MacBook Pro, because I thought the problem only appears on them. I encountered the same problem on a 13" MacBook with completely different apps installed. I suspect more and more that it's a very rare (race) condition / scaling bug in the OSX core that handles multiple display screens. The problem also happens on macOS 11.1 Big Sur.

Screenshot of desktop area where the mouse cursor cannot enter

Screenshot of multiple display arrangement, in System Preferences

Screenshot of another desktop area where the mouse cursor cannot enter


Note: In the linked question, someone has posted a video screenshot of what happens.

13
  • Welcome to Ask Different :) Can you go to System Preferences app -> Displays -> Arrangement tab and check how the displays are arranged relative to each other. Ideally, the cursor should have a clear path to move across relatively from one display to the other. You can also update the question by sharing a screen shot of the preference pane.
    – Nimesh Neema
    Feb 19, 2020 at 17:58
  • @NimeshNeema my arrangement is perfectly aligned and when I move the cursor from one screen to the other, the cursor does not jump in height. It is only the yellow framed box which I cannot access. I cannot put the cursor in the yellow/orange box.
    – Daniel W.
    Feb 19, 2020 at 18:01
  • 1
    That's an interesting development. I would have predicted that the problem go away once you no longer have an extended desktop, but getting worse? Did you try in Safe Mode? I'm wondering if there's something being loaded that's causing this.
    – Allan
    Feb 19, 2020 at 19:05
  • 2
    The problem is too rare to try any mode any period. @Tetsujin my macbook is at desk height while my monitor is on a stand. It's not unusual at all. This is simple offset calculationi and should really have nothing to to with the problem :/
    – Daniel W.
    May 31, 2020 at 17:34
  • 2
    I've just experienced the same issue. Using 15' macbook with extra display, although aligned differently from op: top(external) to bottom(15'). The invisible blocking region is on bottom left on the external, and when I disconnected the external, the invisible blocking region persists and got bigger on my 15' display. Change res and alignment didn't help. Rebooted, the problem gone,... Let's wait and see.
    – Vincent
    Nov 6, 2020 at 2:03

3 Answers 3

154

I had this same problem and it has been driving me crazy. While I still don’t fully understand the cause of the bug I finally found a way to fix it.

First a note, I think this problem only happens when the zoom accessibility mode is enabled, though it occurs even when not zoomed in. And further, it might be related exclusively to full screen zoom.

I have a keyboard shortcut that turns full screen zoom on and off (⌘⌥8 by default), configured in accessibility settings. Whenever a region of one of my displays becomes inaccessible, I just zoom in and right back out and the inaccessible regions are gone.

I hope this helps.

19
  • 12
    This actually worked for me too. Nov 16, 2020 at 20:26
  • 6
    100% this fixed it for me. I use the zoom setting constantly, would recommend to anyone.
    – doublejosh
    Nov 18, 2020 at 0:11
  • 7
    I was so sure this wouldn't help but … oh wow, it works! This saves me so many reboots! Thank you!! 🙌 Nov 19, 2020 at 7:48
  • 27
    Thank you for tracking this down. I have CTRL-Scroll setup for zoom. I was able to clear out the unavailable region by simply zooming in a bit and back out.
    – pauln
    Jan 25, 2021 at 17:45
  • 5
    Oh my god, thank you for this. Before I had to restart my system to fix it.
    – Beau
    Sep 4, 2021 at 1:09
4

Move the white bar at the top of the smaller display to the larger display. I had the exact same issue (27" monitor and 24" monitor). I was able to move the "box" up and down the right side of my "primary" monitor, by sliding one display up and down on the arrangement tab.

Then I Googled how to select your primary display on macOS:

https://support.apple.com/en-us/HT202351

The invisible box is gone now. I think the issue is when you set a smaller display as the primary monitor, there is some gap created near one corner that basically equals the number of mixing pixels between the two monitors. But only at one particular corner, not all of the mixing pixels. I would have had a nice long invisible rectangle + an invisible box if that were the case (2560x1440 > 1920x1080).

5
  • 2
    Unfortunately this answer did not help me, when I had the same issue. Switching the primary display moved the invisible box, but it never went fully away.
    – Christoph
    Oct 20, 2020 at 15:02
  • 1
    Same as @Christoph, I have the same issue and changing the primary display didn't help. Nor did re-dragging my screens, disconnecting some (I have a MB pro and two monitors, one of which is vertically rotated - for code editing :) ). Nothing helps but a restart of the Mac Nov 3, 2020 at 9:06
  • 1
    Thanks for sharing, interesting approach and worth trying but didn't help me either.
    – Daniel W.
    Nov 3, 2020 at 10:46
  • 1
    Just by way of contrast, on MacOS 10.15.7 I was having exactly the problem described, and moving the menu bar has appeared to leave me with no "dead spots". This was a three-monitor setup with the laptop screen positioned underneath the two others side-by-side. Changing Arrangement settings had not appeared to remove the problem.
    – holdenweb
    Jan 25, 2021 at 8:53
  • This fixed it for me! Really simple May 27, 2021 at 15:56
0

I was having this same issue. It turned out to be an invisible iTerm2 window. Closing iTerm2 solved it. I only figured it out when I copied multiple lines and clicking in the invisible area generated the iTerm2 warning for pasting multiple lines.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .