2

I have a Plantronics C5220 USB-C headset and when I use it on Skype I can hear myself in the headset speakers, that's what they call "sidetone" (or voice feedback).

Apparently there is a native option on Windows OS to disable it, I wonder if there is any way to achieve that in macOS ?

I have already been through sound settings and midi/audio settings.

2
  • Is what you hear immediate, or is there a slight delay? It is entirely possible that your Skype partner has their volume so loud that their mic is picking up the output of their speakers and routing it back to you - out of sync so it doesn't register as feedback. Feb 19, 2020 at 5:15
  • There is no delay at all, I would tend towards feedback, indeed, in Skype's settings, when I'm testing the headset, I can also hear the same feedback.
    – Thomas
    Feb 19, 2020 at 7:56

1 Answer 1

1

I got an answer from the Plantronics (Poly) support team, all their products have sidetone enabled.

On macOS, the driver (Plantronics Hub) they provide is not that good and doesn't allow to disable sidetone which is probably firmware enabled.

I've also tested the headset with the 3.5mm jack on my smartphone and the sidetone is not present that why I tend to think that the sidetone is handled by either Plantronics Hub or headset firmware.

1
  • Please note that if you use the Jack on your mac too (without using the USB adapter), you will also get rid of the playback (side tone). So this is definitely a problem related to the firmware of their USB controller (I mean the little black thing with volume +/- and mute buttons).
    – galeop
    Mar 27 at 10:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .