5

I'm using quite a few input languages on my Mac (10.14) and found out that whenever I open a new app, the default selected language will be Chinese (Pinyin as shown on the photo below). And I believe it has to do with the order that my Input Sources are selected. I would like to put the English keyboard (U.S. International) language as default, however, there is no way of simply pull it to the top. I hope somebody can give me suggestions on how to do it. Thanks!

screenshot of list of input sources on my Mac

  • Which version of the os? On Catalina you can make one language primary... – Solar Mike Feb 17 at 8:40
  • @SolarMike, sorry, forgot to mention, I'm using OS Mojave 10.14.4 – Mykola Servetnyk Feb 17 at 8:59
  • Drag a different preferred language to the top of the Preferred language list. First one will display the language of your OS accordingly. – Udhy Feb 17 at 9:22
  • Is your top preferred language always English? If so, this looks to be an anomaly (bug). It is also possible that U.S. International is not being perceived as a related language to English (see my reply below). Have you tried other Input Sources such as "U.S." or "British" with the top preferred language continuing to be English? – Alper Feb 17 at 15:40
  • @Alper, yes, but Chinese keeps to be first on a list. – Mykola Servetnyk Feb 17 at 16:09
1

It is impossible to re-order them. To fix it, you want to tick Show Input in menu bar. This will cause a little icon to appear in your menu bar with your language:

image

(The icon might be different depending on the language set). If you click there you can change the language to U.S. International - PC.

If you still want to use another language for a specific app (say you want to use English for all apps except Safari where you want to use Russian), you can either:

  • Change the language in the menu bar
  • Keep Automatically switch to a document's input source checked which will remember your last language for that application
| improve this answer | |
2

If you want a certain input source to be your preferred keyboard layout, you should make its related language to be your top preferred language through the System Preferences > Language & Region setting. To do that, just drag that language (I assume this is in your case "English") to the top of the "Preferred languages" list in that setting.

If you wish to type in a language other than your top preferred language, you can choose a related input source from the Input menu that appears at the top right of your system menu bar. Because you already have more than one input source, the Input menu should already be appearing on the system menu bar. If not, make sure the "Show Input menu in menu bar" option is enabled in the System Preferences > Keyboard > Input Sources settings tab whose picture you have shared with us.

From the Input menu, you can also switch to other input sources that you have included in your keyboard settings. You can also use the keyboard shortcuts ctrl ⌃ + Space ␣ and ctrl+Alt ⌥+Space␣ to choose the previous and next input source, respectively, included in your keyboard settings. Go to System Preferences > Keyboard > Shortcuts > Input Sources and click on "Restore Defaults" if these two shortcuts are not working on your computer.

Hope these help.

| improve this answer | |
  • 2
    I'm sure he knows all that already. The problem he wants to fix is the default input source which is active when he opens a new app, so he does not have to change things. – Tom Gewecke Feb 17 at 13:41
  • I am not sure what @Mykola exactly knows but I added a paragraph to my recommendation that I think might solve that problem as well. Thx for the comment. – Alper Feb 17 at 14:11
  • His screenshot tells you that English is already selected as the preferred language. But the default keyboard is chinese. The problem is how to change that. – Tom Gewecke Feb 17 at 15:09
  • I don't think you can infer that English is the preferred top language with certainty when the described problem is being observed. It is quite possible that the top preferred language has been changed temporarily to English so that this picture can be shared. If the issue is as you described indeed, it would be best if the Language & Region setting is mentioned in the OP as the situation then seems to be an anomaly. – Alper Feb 17 at 15:21
  • @Alper, thanks for suggesting, but what you suggested is not quite related to my question as Tom Gewecke said, I want to fix default input language. Also, I want to confirm that English stands as a primary preferred language on my Mac. However, I am indeed located in a Chinese speaking country at the moment, but it would be weird IMHO if it matters. – Mykola Servetnyk Feb 17 at 16:07
1

You may be able to reset the default keyboard by rerunning the Setup Assistant. How you do that probably depends on the MacOS version. Here are two references:

http://www.theinstructional.com/guides/how-to-re-run-the-os-x-setup-assistant

I cannot activate Setup Assistant Mac OS Catalina 10.15.1

I have not tested this possible fix.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .