I have an upgraded MacPro 5.1. I recently installed Catalina and had to use a patch from dosdude.

I had to disable SIP using crsutil disable command. I successfully installed macOS Catalina and the system runs great.

Since I did this I am having problems getting back in to Recovery Mode using the usual boot shortcut ⌘ CommandR key combo.

I have an RTX 580 graphics card in though. I don’t see the full boot screen but I am pressing both keys as soon as I hear the boot chime. Can anyone offer any advice?

  • If you don't have a Mac-flashed card you can't see the screen before login. the usual trick is to keep your original GPU for if you need to do anything like this.
    – Tetsujin
    Feb 15, 2020 at 17:35
  • Thanks for you’re time in-replying and the information you provide. Feb 16, 2020 at 9:27
  • Steven, please don’t post thank you comments all over. If you want to thank someone, the accepted method is to up vote. I encourage you to take the Tour so you get a better understanding of how the site works and get the best experience.
    – Allan
    Feb 16, 2020 at 18:28

4 Answers 4


On Dosdudes's website, they make a note that if you use APFS, you will not have a bootable Recovery partition:

  1. Select the disk or partition you want to install on, and erase it, ensuring to use either Mac OS Extended (Journaled), or APFS as the filesystem type. If formatting an entire drive, ensure GUID is selected. -- Please note that if you use APFS, you will not have a bootable Recovery partition.

Emphasis mine

Granted, the install document is from the "High Sierra" page, but APFS implementation between High Sierra and Catalina isn't so different that Recovery will work in one and not the other.

As for your graphics card, I highly suggest flashing (IMO, this should have been done prior to installing your Catalina patch so you could diagnose issue if/when they arose). See this answer for some links on how to do this procedure.

If you need a Recovery Partition, try Internet Recovery or boot from a USB installer.

  • Thanks for you’re time in-replying and the information you provide. Feb 16, 2020 at 9:27

If you are looking for a way to enable or disable SIP, then you could try installing rEFInd to boot from the EFI/boot folder in the EFI partition. (Basically, include the --usedefault option when issuing the refind-install command.) You can then select to boot rEFInd from the Startup Menu. The rEFInd Boot Manager has options to enable/disable SIP and to run the gdisk partitioning tool. The rEFInd Boot Manager also has a driver which allows rEFInd to access APFS formatted partitions for the purpose of booting both macOS and macOS recovery. However, I do not know if this would be compatible with modifications made by the patches.

  • Thanks for you’re time in-replying and the information you provide. Feb 16, 2020 at 9:28

I have Catalina on a Mac Pro 5,1 and Recovery mode works fine. I do have an EFI enabled video card, you could try booting into recovery using stock GPU. Another thing is if you are using a wireless keyboard, you have to press command + R after the chime, or it won't work.


I have found a solution, a dumb solution, but a solution. This appears to be a software bug. The solution is to retry, retry, and retry.

  1. Shut down mac
  2. hold down Command+Option+R and press power button
  3. release Command+Option+R when you hear the mac boot tone
  4. when you see the Earth picture, select wifi network, and input password
  5. wait ~5 minutes for it to download.
  6. mac freezes on the black screen with the white apple logo.
  7. frown, hold the power button down to shut off the mac, and then repeat the above steps

6 alternate: The black screen with the white apple logo has a white loading bar beneath it (this is good!). 7 alternate: Wait for the white loading bar to complete like 2-4 times. Behold, the Catalina macOS Utilities screen.

I tried like 8-10 times before it suddenly worked. Super lame, non-deterministic, but at least I got it to work. I hope this helps out others.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .