0

I have a 13" 2018 MacBook Pro. My System Integrity Protection is off, and T2 security is set to None. After an update to MacOS Catalina 10.15.3, my mac would stay at the bootup screen with an apple logo. I salvaged all my data in recovery mode and tried to reinstall MacOS from there. I ended up getting A software update is required to use this startup disk error in recovery. I then completely wiped the internal SSD, and using another mac and disk drill made a bootable USB with MacOS 10.15.3. I booted that and got the same A software update is required to use this startup disk error in recovery. I tried to reset the mac to its original OS after that with Shift+Option+Command+R, but after loading with a rotating earth for a few minutes I get an exclamation mark sign over that earth with the following below it:

apple.com/support  
-1008F

Regarding the inability to boot the MacOS USB stick, I've read that the newer macs can only boot from APFS drives. However, I do not know how to do that. After using disk drill to flash MacOS to a USB, I tried using a disk utility option Convert to APFS..., but that threw an error.

I have no idea what to do anymore, and would rather not go to an apple store to fix this. Is it even possible for a genius bar person to fix the software? How could I fix this myself? I do have access to a few decently sized USB drives and a tri boot Windows/Linux/MacOS computer, but no professional tools.

I would like to add I have not been able to install linux either onto my Mac, and not even rEFInd.

3
  • 1
    There is already a tool in the OS installer - see support.apple.com/en-us/HT201372
    – red_menace
    Feb 15 '20 at 4:54
  • What is the model/year of the other Mac? What version of macOS does this Mac have installed? Do you have any external HDD or SSD where you could install macOS? Feb 15 '20 at 5:40
  • The other mac is a mid-2014 Macbook pro 13" running MacOS 10.15.2. I have a 32 and 128 gig usb stick. I have tried using the terminal on this mac to create bootable media, but the other broken mac instead boots into internet recovery, then throws an error no matter how I flash macos onto the USB.
    – Devin
    Feb 15 '20 at 6:00
1

According to everymac.com, your 2018 Mac should be able to run macOS 10.13.6. You could try using the 2014 Mac to download High Sierra from this website. This download should be the latest High Sierra macOS 10.13.6. You can the use the instructions from this website to transfer High Sierra to a flash drive. After booting from the flash drive, use the Disk Utility to erase and APFS format the internal drive. Finally, try installing High Sierra. If successful, then you can try upgrading to Catalina.

9
  • 1
    Unfortunately, the standard installer for macOS High Sierra 10.13.6 is just build 17G66, but the MBP 13" Touch/2018 requires build 17G2112 or later. But a standard Mojave installer should work. Feb 15 '20 at 9:44
  • @GordonDavisson: You have a point. Unless Apple releases a macOS High Sierra 10.13.7, you will have to use the Mojave installer. Feb 15 '20 at 14:05
  • I was able to download MacOS Mojave from the app store. As I had previously mentioned, I had formatted the MacOS disk. Now when I plug in the installation media for MacOS Mojave, it boots into internet recovery, since regular recovery has been wiped. It then wants me to install MacOS Catalina form the Internet, which is not what I need. I have also noticed that once I boot into the USB drive and keep it plugged in while the mac boots into internet recovery, I get thrown the -1008F error again, but if I unplug the USB stick then it boots into regular Internet recovery.
    – Devin
    Feb 16 '20 at 2:39
  • @Devin: I assume you used the correct createinstallmedia command to create the USB macOS Mojave installer flash drive. I assume you are booting to the USB flash drive by selecting the drive from the Startup Manager. Are both assumptions correct? Feb 16 '20 at 2:48
  • Yes. I have also used Disk Drill, which is a graphical tool which does the same thing. I am pressing option at bootup to boot the USB. Note that since I have formatted my disk, there is no recovery, so my mac boots internet recovery and downloads macOS Catalina, not letting me install Mojave. Thanks for all the help again.
    – Devin
    Feb 16 '20 at 3:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .