0

I have a dual-band Netgear router, an iPhone 6 and a MBP 13" early 2015 (Both devices were on Beta tester OS but not anymore).

When I try to connect to the 5GHz network from the router I end up connected but having a self-assigned IP like so (Happens to both my devices):

When I connect to the 5GHz using my phone I also get a self-assigned IP

After connected my devices will assign it self an IPv4 that looks like 169.254.xx.xxx) and obviously I cannot connect to the Internet using this IP.

When I connect to the 2.4GHz, the network becomes insanely slow (Even though the signal strength is at the best), I pinged my router (192.168.1.1) and I end up with average latency of 322ms and a 5.4% Package loss (BTW I'm right in front of the router). Speedtest.net and speediest-cli gives up/download speed test at around 3/1 mbs.

All of my flatmates says the WiFi works fine for them (and they are further away from the router than me)

Here are the solutions I found and tried:

  • Turning WiFi connection on and off
  • Rebooting my Mac and router
  • Forgetting the WiFi and connect again
  • Manually setting IPv4
  • Setting my DNS to 192.168.1.1
  • Disconnect, deleted all the .plist files listed in tutorials and attempt to connect again
  • All of above tried again using terminal with sudo
  • All of above tried again using terminal with sudo but with csrutil disable in Recovery mode

None of them worked.

Is there another solution that I haven’t tried? Why does it keep happening to me but not my flatmates? Is there a way to stop Apple devices from self assigning IP addresses?

All I want is to be able to connect to the Internet using the 5GHz (because it working for all others) or at least not having such high latency with the 2.4GHz

  • Ok.. a few things...*All* devices (Mac, PC, IoT, whatever) have the capability of a self assigned IP. It does that in case there's no DHCP server they can continue to communicate - you can't disable it. Second, does it have to be 5GHz? Can you try 2.4 to see if the problem goes away? And finally "why it keeps happening to you" is a metaphysical question.. karma perhaps? But ultimately, we can't answer that one. – Allan Feb 14 at 3:31
  • What you might want to try is going into the router and removing the DHCP lease of your devices. If you can't delete, try a reserved IP (it will get the same address every time). I had an iPhone that exhibited the same issues until I reset the router (flush the DHCP lease table) and would start working again. – Allan Feb 14 at 3:35
  • Hey Allan, thx for the advices, I'll look into those. BTW I had to use the 5G because the 2.4G is frustratingly slow (I mentioned about the high ping to router, it happens almost at all times). – Sta99er Feb 14 at 5:37

You must log in to answer this question.

Browse other questions tagged .