1

When I try to text on Mac, and I hit the return button to send it, it will highlight the message instead of sending it (as if I wanted to copy the message). Does anybody know how to help with this?

  • Welcome to Ask Different. :) Could you please edit your question to include the version of macOS you're running? – Monomeeth Feb 14 at 3:27
1

That is a strange, because pressing the return button in Messages on macOS 10.14.6 sends the message as you expected it to do.

Are you using the return key on a numeric keypad? That might be the reason?

The other option is to press +return which should send the message. Other than that, you can try signing in and out of Messages app on the Mac, and ensure message forwarding is enabled in the iPhone's messaging settings. I'll keep you posted if I find out any other setting to change it.

Edit

I just found that you can potentially make the return key act as send message by creating an app specific shortcut in Keyboard Settings. I'm not 100% sure it will work but give it a try?

Go to System Preferences->Keyboard->Shortcuts->App Shortcuts then add a new shortcut and select the Messages App from the Application Dropdown menu. Enter the exact menu command name Send Message. Now in the keyboard shortcut box it won't let you just press the return key, so you will need to press fn+return but it should display just return in the box.

Now go back to the Messages app and see if it will require you to press the fn key before pressing return or without the fn key? If not you can just remove that app shortcut from the keyboard settings.

I've attached an image what the shortcut setting looks like.

enter image description here

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .