3

For seemingly no reason, the macOS hotkey to control the brightness (control + F1/F2) of my LG UltraFine secondary display has stopped working.

Also, the Sound Preferences do not show LG UltraFine speakers anymore, so I cannot set the sound output to that display.

When I try to open LG Screen Manager, it quits immediately.


Can anyone else using LG UltraFine (23.7" 4K, specifically) confirm facing this issue? Any suggestions on how to fix this?


Update:

This Apple bug/personal oversight has become a nuisance on my home setup. Not only can I not control the display and sound on my UltraFine monitor through the iMac, I am unable to send the sound output from my iPad to the monitor. All this was earlier working without any problem.

When going to Apple > About This Mac > Displays, the UltraFine display shows up, implying that the monitor is being identified. But the sound and brightness controls are not working.

I have tried three different devices, an iMac, an iPad, a MBP. Neither worked, leading me to believe that the issue is with macOS/iPadOS.

  • 1
    It's always very important to explain any steps you have done so far to resolve this issue. Or have you not yet tried anything? – X_841 Feb 13 '20 at 8:54
  • 1
    @X_841: what steps could I take apart from examining System Preferences and trying to bypass to LG Screen Manager? – displayName Feb 14 '20 at 0:35
  • Am facing the same issue. The controls for sound/brightness appear and disappear suddenly. No idea how to reproduce it. I am using the Thunderbolt connector. – jgr0 Sep 4 '20 at 19:48
  • @user209139: Unplug your monitor from the iMac as well as from the power source. Then start your iMac in safe mode once. Then restart the iMac. Then plug the monitor back to the power source. Then connect it to the iMac. It should work then. – displayName Sep 5 '20 at 2:32
2
+50

To restart the brightness controller, in Terminal do sudo killall corebrightnessd (you'll be prompted for your password). Or Force Quit it a couple of times in Activity Monitor, where you can check that it has restarted by looking in "CPU Time" column which should now be near zero.

I use an old Apple Cinema Display and have to do this every so often.

For your other issues, you may wish to re-plug the monitor connection. This range of monitors have known issues with macOS.

  • Neither the command worked, nor replugging the monitor. :( – displayName Feb 23 '20 at 18:23
  • I take it you mean the command ran buy didn't solve your problems? – Matt Sephton Feb 23 '20 at 18:25
  • I want to be able to use the regular keyboard shortcut (Ctrl + F1) again. Running your command did not reinstate that capability. – displayName Feb 23 '20 at 18:27
  • 1
    Trophy, for participation. :D – displayName Feb 24 '20 at 13:29
  • 1
    Much obliged! Thank you – Matt Sephton Feb 24 '20 at 14:01
1

I spoke with Apple Support and the representative tried to help me solve this problem, but to no avail.

The only thing that session managed to get done was have my iMac restarted in Safe Mode. It did not solve the problem, but in the process my UltraFine's display's orientation changed. (I use it in portrait; It got reset to landscape.)

Since it changed something, try that first.


Next, while moving my desk I had to disconnect my UltraFine and iMac. When I plugged them back to another place, I started the iMac first without the display connected to it. Then I plugged in the power cord of UltraFine. And then I plugged the display's cable to iMac.

For reasons unknown, the brightness and volume controls came back to life.


I know this isn't a logical answer. But it worked, so issued in public interest...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .