1

I’m entering some less-used characters using option-key combination, eg option-o for ø on US layout (or ó on Polish layout). Unfortunately, some programs (namely IntelliJ/Android Studio) interpret such shortcuts on their own: in the "Find in Path" window, option-o toggles "Words" and so the character under option-o cannot be entered into search query (it can be typed in some other editor and pasted, but that's a short term solution). Unlike many other in IntelliJ, this shortcut is hardcoded and can not be turned off in preferences.

Can I make the system handle such key combinations and prevent rogue programs from hijacking this valid input?

/edit: I am not asking about alternative ways of getting those characters. For Polish layout users, option-(A,C,E,L,N,O,S,Z,X) are inherent part of the keyboard, as natural as Q, W or E being where they are.

1
  • Does the popup menu of accented characters produced by press/hold work in those apps? If so, it would be another way to make them. – Tom Gewecke Feb 11 '20 at 14:58
1

A alternative would be to create a custom keyboard layout where the characters that cause a problem are remapped to other convenient keys with Ukelele.

You can also try a keyboard shortcut for the problem characters via: System Preferences > Keyboard > Text > Replace With

0

Option 1

There is no way that I am aware to directly resolve this that I am aware of however using the option keyboard entry is not the only way to do this...

For example all oolout characters ö, ï, ë etc. can be entered by entering + U then you'll get this symbol:

Underlined oomlout

You can then press the key you'd like i.e. o, i or e and you get the accented version, this also works for:

  • U = Oomlout ¨
  • I = Caret ^
  • E = Acute ´
  • N = Tilda ~

I've not got InteliJ enabled but this certainly always worked for me.

Option 2

An alternative solution would be to create an App Shortcut that overrides the original, this may or may not work depending on how the application implemented the original shortcuts... It will only work for menubar shortcuts too.

  1. Go to System Preferences.
  2. Keyboard.
  3. Shortcuts
  4. App Shortcuts
  5. Click +
  6. Choose InteliJ as the 'Application'
  7. Set the 'Menu Title' to be identical to that in the menu item of the problematic shortcut you are trying to replace
  8. Click 'Keyboard Shortcut' and enter any other shortcut that isn't used.
  9. Press 'Add'

This should remap the menu item that was blocking this shortcut, however if there was no menu item, just a hotkey this won't resolve the issue.

Option 3

Contact the developer of IntelliJ and point out the issue and see if they can fix this for a future release.

4
  • 2
    The OP asked specifically about ø. Do you have another way to get that one? – Tom Gewecke Feb 11 '20 at 14:48
  • Unfortunately, there is no menu item. It seems to be a dirty hack, not even coherent with the rest of IntelliJ, which has customizable shortcuts. There are tickets tangential to my issue dated 2012 so it's safe to assume devs are not willing to get it done properly. The problem doesn't manifest itself on Windows because AltGr is in fact Ctrl-Alt, so the shortcut is not triggered. I've edited my question to explain why using alternative input is not possible. – Agent_L Feb 12 '20 at 11:53
  • @Agent_L Have Polish Mac owners not found some convenient workaround for using this app over the years? Do they just use something else instead? – Tom Gewecke Feb 12 '20 at 12:58
  • @TomGewecke It's only in 1 window of the app, "find in path" (Cmd-Shift-F). All my mac-using coworkers just learned to live with it (eg. type in TextEdit and copy-paste). I'm bit scared that I may encounter the issue in other programs as well, that's why I'm looking for a generic solution to keyboard hijacking, not just this one. – Agent_L Feb 12 '20 at 15:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .