1

In "Languages and Region" I have set my only language to be Cymraeg (Welsh). It is the only one in the list of preferred languages. However, the date in the top bar is in english.

If I change the language to French it displays the date and time in French. My iPhone can display it in Welsh...

Any ideas?

9
  • have you checked this: In the Date & Time pane, make sure that ”Set date and time automatically” is selected – Udhy Feb 10 '20 at 11:35
  • I have. Still no luck. – HMPARTICLE Feb 10 '20 at 12:06
  • @HMPARTICLE What's your system verison? (Beth yw fersiwn eich system? < don't know how well the Google Translator works ;-)) – klanomath Feb 10 '20 at 12:15
  • I wonder if it's because there is no general system localization in Welsh. You might try setting the OS to Irish and see if the same thing happens. – Tom Gewecke Feb 10 '20 at 13:06
  • I seem someone do it on YouTube for an older version of macOS/OSX. Yea it does the same thing with Irish. So annoying that Ubuntu can do this with ease (although some of the translations are interesting) – HMPARTICLE Feb 10 '20 at 15:18
1

Try using this command in Terminal:

defaults write NSGlobalDomain AppleLocale -string cy_GB

It worked for me in 10.13, but have not tested in later MacOS versions.

This question indicates it may no longer work.

Mojave and its non-respect of the AppleLocale preference

e

2
  • Is it suppose to work immediately? on login/logout thing? – HMPARTICLE Feb 17 '20 at 10:20
  • logout/login. But not in Mojave and Catalina so far.... – Tom Gewecke Feb 17 '20 at 13:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .