1

Every night my MacBook turns off and updates.

I've switched off every System Preference I can find but still, if I go to sleep and come back, it's either trying to restart on account of the Software Update and an app which has an unsaved state is blocking it, or it's off.

What can I do to disable any and every Software Update attempt?

Screenshot of the Software Update System Preference pane showing updates are disabled automatically.

  • 1
    Is your Mac managed with MDM or profiles in system preferences? If so, please edit that into the question. – bmike Feb 9 at 21:57
  • 1
    TBH, it sounds like your problem is that your Mac keeps updating for no reason whatsoever. This isn’t a normal state. You should try re-installing macOS to attempt to fix the root issue, not workaround the symptoms. – Florian Wendelborn Feb 9 at 22:06
  • Would that help? "Prevent your Mac from downloading updates in the background" support.apple.com/en-us/HT207251 – Alper Feb 9 at 22:57
  • So it tries to update even when no updates are available? – Alper Feb 10 at 11:07
1

If you open the App Store and under the App Store menu item click on preferences. This opens a panel where you can change or turn off updates. This is for High Sierra. It may be different in Catalina but I thought it was worth the effort to check.

| improve this answer | |
  • thanks for the reply, sadly its unchecked there too – Alex Feb 9 at 22:38
  • 1
    Ugh! i thought I had it. Sorry, but if i remember anything i'll let you know!! – jmh Feb 9 at 22:40
0

I'm posting this as an answer in the hope that this will solve someone elses problems.

Scenario: every time I left my backups to run or downloads running in the background I would leave my machine alone and prevent the machine going to sleep using the Energy Saver settings. I would almost always come back to find the computer turned off and then find that an Software Update had been applied but my backups had been killed and I was either switched off or the machine was back at the login screen having restarted.

I spent a huge amount of time looking through the system logs and tracing events and found that the constant logging out and restarting was down to a setting deep in the system:

System Preferences > Security & Privacy > Privacy > (unlock the lock at the bottom) > Advanced

You will now see a little checkbox called "Logout after 60 mins of inactivity"

It took me weeks to find this, and a lot of sanity and paranoia. I hope this helps someone somewhere!

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .