8

I’m not seeing a way to choose a different default browser in the Gmail App's "Settings" dialog and I want to use Firefox:

Gmail settings dialog iPADOS

How can I circumvent Google's restriction on opening links in Gmail using only Chrome or Safari on iOS 13.3 or iPadOS 13.3?

9

The only way I found was through the "Share" facility. Basically, the procedure is to add Firefox (or a another browser of your choice) as a sharing option so it can be selected when the link in a Gmail message is long-pressed.

"Share" Menu Configuration:

The following illustrated procedure uses Firefox to modify the list of apps available as a source to share with to add Firefox. However, you can add Firefox as a sharing source from some other app if you care to. Procedure will still be the same. Please note the images are cropped to only show the parts of the interface you need to work with

Screengrab1

Screengrab2

Screengrab3

Screengrab4

Screengrab5

Using Firefox with Gmail:

Using a Gmail message, I'll now illustrate how you can open links with Firefox using a long-press on the link:

Screengrab6

Screengrab7

Screengrab8

That's how you can circumvent Google's restriction on using a browser other than their own and Apple's Safari. Hopefully a future version of Gmail will make all this unnecessary, but until; they do...

|improve this answer|||||
  • 4
    Superb answer! Great annotations! – IconDaemon Feb 8 at 16:41
  • 1
    @IconDaemon If I can save others the grief of solving the same problem that burned my cycles, always happy to. Indeed, posters to StackExchange have helped me innumerable times working at the IT coalface. Feel it's right to put something back into the community. Thanks IconDaemon! – F1Linux Feb 8 at 16:44
  • This no longer seems to work. I followed the instructions but do not get "Open in Firefox" as an option. – Adam_G 2 days ago
  • @Adam_G I just tried it and it's working for me. I'm using Firefox v24.1 (17574) on IOS 13.4. However, the long-press can be overly sensitive and go straight to open the link in Safari. Might be down to your long-press technique. – F1Linux 2 days ago
  • Thanks, unfortunately that's not the issue I'm having. When I long press a link I get a pop-up that looks like this: imgur.com/ehtPMDc – Adam_G yesterday

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .