I've recently tried to update my Macbook Pro late 2011 using dosdude's Catalina patches, as it is not officially supported. It worked fine, but after using it for a few days, it suddenly froze and crashed. I tried to restart it, got at the login screen but it would just try to sign in and freeze again on a white screen. I also have red horizontal lines in my screen. I have tried going to recovery mode, doing a SMC, doing a NRAM reset, going into safe mode, but nothing seems to work. I also tried the hardware test which told me there was no trouble. The internet recovery does boot up, but after entering my WiFi password it starts loading and eventually gets stuck on a white screen again. Even trying to use an installer USB get's till the point whether I would like to start from my Macintosh HD or USB, but after loading, it just freezes again.

I went to a even worse path by resetting the SSD, because I found some posts telling that the SSD might be corrupted. This means I have no backup unfortunately.

What can I do to resolve this issue?


The comments suggested to record it. I have a image of the last logging (using verbose mode) that I could see before the screen went dark and started bootlooping.

enter image description here

  • If you're doing Internet Recovery, and it's crashing during boot and most likely has nothing to do with patched Catalina. Try Verbose Boot (Hold ⌘-V while booting) and see where things get stuck
    – Allan
    Commented Feb 7, 2020 at 22:22
  • I did that, but that will also crash after a while. I think last time I did that it said something like undetected CPU, I will check it out tomorrow!
    – Jason
    Commented Feb 7, 2020 at 22:33
  • If you can, record with your phone so at least you can "stop" it right before it crashes.
    – Allan
    Commented Feb 7, 2020 at 22:38
  • @Allan I've added a snapshot of the recording, I think it has something to do with either the "unsupported cpu" or "couldn't open channel with RPCI protocol". I have taken out the SSD and installed a High Sierra on it using a different Mac, so technically speaking it should work software wise as it has the recommend OS for it and also a Recovery HD, but it still doesn't seem to work.
    – Jason
    Commented Feb 8, 2020 at 14:40
  • 1
    I’ll have to research that error. There’s another test you can try..boot Ultimate Boot CD. I was able to positively diagnose a bad GPU with the included video tests. There’s also CPU and memory tests. If it’s hardware, well know, but it may be time to replace that a Mac.
    – Allan
    Commented Feb 8, 2020 at 15:06

1 Answer 1


Thanks to @Allan, I was able to find out how to solve my issue. I did the following:

  1. I had another Mac's SSD be cloned using a program called carbon copy cloner to my Macbook's SSD.
  2. I ran the High Sierra installer on that Mac, specifying the Macbook's SSD as final medium (this added a recovery HD)
  3. Boot into single user mode to tweak the NVRAM using this guide, and this question was also very relevant.
  4. Step 3 needs to be redone every time you update your OS. Note: your brightness function keys will also not work anymore!

Important command for temporary fix:

sudo nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00

Transcript of the MacRumors thread in case it get's removed:

First of all, it is possible to successfully boot a MBP to OS X while still using the failed GPU, after you remove the AMD drivers by booting in command line mode (CMD+S) and entering these commands:
1) fsck -fy (to check a disk)
2) mount -uw / (mount a root filesystem with read/write permissions)
3) sudo mkdir /AMD_Kexts/ (make a directory to store the AMD drivers in case you'll need them in future)
4) sudo mv /System/Library/Extensions/AMD*.* /AMD_Kexts/ (move the AMD drivers)
5) sudo rm -rf /System/Library/Caches/com.apple.kext.caches/ (remove the AMD drivers cache)
6) sudo mkdir /System/Library/Caches/com.apple.kext.caches/ (just in case OS X will be dumb and will not recreate this directory, I am creating it for OS X)
7) sudo touch /System/Library/Extensions/ (to update the timestamps so that new driver caches - without AMD drivers - will be definitely rebuilt)
8) sudo umount / (umount a partition to guarantee that your changes are flushed to it)
9) sudo reboot

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .