1

I've got a Mac running 10.10.5 Yosemite, trying to upgrade to 10.11 El Capitan. When I run the installer, it claims installation requires 7 Mb of disk space, it installs some files, and ends with "Installation successful".

But the OS is not updated: after a reboot 'About this Mac' still shows it running Yosemite.

The same thing happens on this Mac when running the 10.12 Sierra installer. The goal is to get to Mojave, but that installer won't run at all so I'm trying incremental updates.

In both cases I made sure to download the full (~6 Gb) installer beforehand (from the app store), and I'm running the installer from the mounted disk image.

What could cause this error, and how do I get rid of it?

10
  • Where did you get the installer from, how is it called? – nohillside Feb 7 '20 at 15:07
  • Installers are from the Apple app store. The El Capitan one is called 'InstallMacOSX.dmg' – Hobbes Feb 7 '20 at 15:13
  • Good. If I remember correctly the issue has come up before. Searching the site from the iPhone is a pain though, so I hope somebody else is able to find the post – nohillside Feb 7 '20 at 15:29
  • updates-http.cdn-apple.com/2019/cert/… - did you try to check this for ElCapitan – Udhy Feb 7 '20 at 15:34
  • 1
    @GordonDawson If you follow the instructions in my answer, the drive that will get wiped is the external drive that will contain the installer. Once you have that, you can boot from the external drive and run the installer, which will upgrade the OS on your internal drive and leave its data intact. – Hobbes May 17 '20 at 11:04
1

This is the information I missed. I had downloaded a .dmg file, this installs the 'Install El Capitan' app (containing the full 5 GB installer) in the Applications folder. I was expecting it to install the OS instead.

The linked instructions show how to create a bootable installer on an external drive from the .dmg.

  1. connect an external drive
  2. Use the 'createinstallmedia' command in Terminal

    sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app

You can then boot the machine from the external drive and use it to update the OS on your normal boot volume.

The drawback of this approach is that it erases the external drive.

3
  • What specifically did you miss? It's important to put the relevant parts in your answer because links often go stale (especially Apple's). If you don't include the relevant details here, the answer will become useless. – Allan Feb 7 '20 at 17:13
  • This would be great if you added the size of the full installer by a screen shot or show how to get a md5 check sum of the installer. I bet lots of people don’t get the download completed and verifying that will help lots of people. – bmike May 17 '20 at 12:05
  • Why? Incomplete downloads are indicated by the browser. – Hobbes May 17 '20 at 12:22
0

Try to set the date to 01/01/2016 00:00 (sudo date 0101000016).
There is a known problem with El Capitan installer refusing to install OS X because of expired certificates.

2
  • Have you read the comments below the question? That's not the problem I had. – Hobbes May 18 '20 at 7:58
  • I solved a problem really similar to your problem this way. There is no need to comment like this, feel free to try or not. – 375914 May 18 '20 at 8:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .