1

I've been forced by my relatives to install WhatsApp on my iPhone. I use it only for text messages, so I disabled camera, voice, etc. and, what I thought, was all sounds from it in the iPhone settings.

But once in a while, one of my older relatives decides to make a voice call to me. In that case the WhatsApp app starts playing this annoying ringing which I cannot kill, that is very frustrating especially if I'm at work.

Is there a setting (or some other way) to prevent it from ringing the incoming voice calls?

PS. I do not want to silence my phone completely. Just WhatsApp.

Edit: This is how the settings look like in WhatsApp:

enter image description here

  • So you have tried turning off sound notifications from WhatsApp via (iOS) Settings -> Notifications -> WhatsApp -> Sounds? There are also some sound settings within WhatsApp itself in (WhatsApp) Settings -> Notifications. – Alper Feb 7 at 1:14
  • @Alper yes, the iPhone settings sound for WhatsApp is off. And in the WhatsApp settings itself, there's nothing that says "call sounds" but I still disabled it wherever I could (posted a screenshot above.) But knowing that it's Facebook, I'm sure they'll try to sneak it in anyway. Thus I was wondering how to "force" it via the Apple's own settings. There must be some way.... – c00000fd Feb 7 at 1:24
1

In order to silence the ringer during an incoming WhatsApp call, you can turn off all the "Notifications," and prevent the WhatsApp from accessing your microphone by going to Settings > WhatsApp >Notifications. Please note that this will disable all the notifications on WhatsApp including the chat/message notification.

disable WhatsApp call notification on iPhone

If you'd like to receive sound notification for text/chat and only disable the ringer for incoming WhatsApp call, then you should disable the "Banner" alerts, and prevent the WhatsApp from accessing your microphone by going to Settings > WhatsApp > Notifications.

enter image description here

| improve this answer | |
  • Yeah, but I don't want to mute notification of (text/chat) messages on it. – c00000fd Feb 7 at 18:43
  • I'm sorry. I just updated my answer. Please take a look. Try disabling the microphone and banner alerts by going to Settings > WhatsApp > Notifications. Hope that helps. – Charles S Feb 7 at 19:33
  • Man, these settings are so confusing. It seems like there are 3 places that one can find them in. That first screen with the microphone turned off, how did you get to it? – c00000fd Feb 7 at 23:22
  • I agree. It is confusing. Open the "Settings" app on your iPhone, tap "WhatsApp" and turn toggle microphone off (iOS 12 or later). You may check this article: howtoisolve.com/disable-microphone-to-whatsapp-on-iphone – Charles S Feb 8 at 9:46
  • Hmm. I don't have a setting named "Microphone" in there. And I'm on iOS v.13.1.3 – c00000fd Feb 8 at 9:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .