2

Consider the image

enter image description here

So I downloaded the delta and combo 10.15.2 update for mac osx. I first started noticing something odd when I re-installed catalina on my mac mini 2012 - which is supported.

As you can see I have over 900 gigs of space on this SSHD - it is a hybryd drive, never had an issue with updates previously, never had an issue till today.

For context, I did reinstall, what did that entail:

  • Erasing the HDD that contained the OS (the one highlighted).
  • Installing the OS to that HDD

I am not on beta preview or anything like that and the regular software update states:

enter image description here

I tried installing in safe mode, wouldn't let me. For the reason described above in the first image.

As far as I know there should be nothing wrong with the HDD or no "compatibility issues" with the HDD, previously I was on beta for the last OSX installation High Sierra and all the updates came through including the beta catalina updates and so on and so forth, the reason I decided to reinstall after so long was Catalina beta updates felt like windows vista - nothing would work properly.

I do use home brew and home brew cask to install things but out side of PHP, MYSQL, Atom, Imigmagick and a few other things related to web development I have not installed any software that would be "incompatible" with future updates.

I did originally try to go from 10.15.1 to 10.15.3 but someone on another stack question said no, go in order 10.x.1, 10.x.2 and so on.

So can some one tell me whats going on?

Please tell me this will not require me to erase and reinstall I would be very sad. While it wont take me long to get up and going again I would rather avoid that situation if at all possible.

PS: I don't know enough about bootable USB's when it comes to macs, and while I do back everything up. I would also like to avoid that route as from other stack questions it seemed dangerous or could fail. If reformatting is the only option is there any steps I need to take to make sure the disk is compatible with future updates?

  • That screenshot says you are on 10.15.1 beta, did you enroll in the beta? – unknowndomain Feb 5 at 0:42
  • I did at first but removed the profile shortly after and restarted the Mac. Is there a deeper issue here? – TheWebs Feb 5 at 1:00
  • Did you remove the profile or unenroll beta.apple.com/sp/betaprogram/unenroll ? Just might be related... – unknowndomain Feb 5 at 1:15
  • I believe I removed it, when you go into the software update section there is that details thing when your enrolled. When you click on it gives you the option to remove it? Maybe it was just the profile? Not sure to be 100%. I looked it up and I clicked restore to defaults when I clicked details so I believe that removes the profile and Unenrolls me – TheWebs Feb 5 at 2:01
2

I found a solution:

So as unknown domain pointed out, I did originally after reinstalling catalina enroll in beta program only because my backups were in the beta installation.

But after realizing I could indeed get the info I needed from my backup disk with out having to be in the beta I unenrolled by clicking detail and restore to default.

As the internet points out that doesnt restore you back to non beta catalina. So what I did was redownload the catalina installation from the mac store and reinstall. I did not loose any data, it just installs it over top the beta version with out any data loss.

This solved my issue and now I am at 10.15.3 as we speak.

I can accept this answer in two days. I hope it helps others who might be in a similar situation.

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .