I'm using Amazon WorkSpaces Client on macOS 10.15.3 with an external USB keyboard. The Windows key ⊞ Win doesn't work. All other keys work except the Windows key; is there any solution or workaround to get Windows key working?

  • 1
    Usually the COMMAND key maps to the Windows key. What happens if you try that? Feb 4, 2020 at 21:36
  • 1
    No response while using command key... I figured out to use Ctrl+esc key for Windows, but that is hectic to use. However I am using latest workspace ver on macOS Catalina ver 10.15.3
    – Kishore
    Feb 5, 2020 at 23:38
  • You may need to contact Amazon tech support, as I have little knowledge of this service Feb 6, 2020 at 18:55

2 Answers 2


By default the WorkSpaces client remaps the ⌘ Cmd on the Mac to Ctrl in Windows. You can disable this behaviour with this hidden preference for the WorkSpaces client:

defaults write "com.amazon.Amazon WorkSpaces Client" remap_cmd_to_ctrl 0

After running this command, quit the WorkSpaces client then start it up again. When you log into your WorkSpace now, the ⌘ Cmd key on your Mac will map to the ⊞ Win key in your Windows VM.

One caveat: if you switch out to another Mac app using ⌘ Cmd + Tab, you'll notice that the Start menu in Windows has popped up when you return to the VM. This seems to be unavoidable.

After making this change, you'll have to use the Windows keyboard shortcuts for clipboard operations like copy Ctrl+C and paste Ctrl+V, rather than the familiar Mac shortcuts. Presumably Amazon changes the default behaviour to make it easier for Mac users to use the clipboard.

I tested with an external USB keyboard (the Apple A1243 MB110LL/B) and observed exactly the same behaviour, so it doesn't seem to be a problem with external keyboards.

Confirmed with WorkSpaces Client

  • After defaults write "com.amazon.Amazon WorkSpaces Client" remap_cmd_to_ctrl 0 I was not able to get used to use Ctrl to copy/paste instead of CMD, so on AWS WorkSpaces' Windows 10 I installed PowerToys and remapped Win --> Ctrl and Ctrl --> Win and everything is back to normal now.
    – Taz
    Mar 9, 2021 at 18:41

I too had the same issue. Even after disconnecting and reconnecting, the same problem continued to exist.

After some time, it was working.

I did restart by closing the AWS window and then re-logged in, and it worked then.
I don't know the exact solution, but it worked.

  • This worked for me. Thanks for suggestion. Mar 8 at 8:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .