0

I try to grant access for google chrome or safari to my microphone and both redirect me to security & privacy section.

There are no plus or minus signs and no apparent way to allow these apps to use my microphone.

I also tried with skype but same story all over again unfortunately.

It seems to me that it is like a deadlock because no system call is activated apparently to enable the plus minus signs. Any ideas?

enter image description here

EDIT:

None of the solutions proposed here worked. I ended up reinstalling MacOS by using Option-Command-R at startup to upgrade to the latest macOS that is compatible with my Mac.

Now everything works. It should have been a problem of the OS installed on my computer.

4
  • 2
    Are you seeing the request pop up in which you can grant or deny permission? If not, at least try rebooting & trying again. Make sure the apps are all up to date [older apps don't know to ask.] There is no way to manually add apps to that list [I have no idea why but you can't] the app must ask.
    – Tetsujin
    Feb 4 '20 at 14:00
  • Yes I'm seeing the popup normally. I tried rebooting. I also tried Safari, which should be automatically updated with the system update. Still I cannot add/remove any apps in this section. Feb 5 '20 at 15:58
  • Late thought… idk about Chrome, but Safari doesn't appear in that list for me either. Instead, Microphone perms are in Safari prefs, Websites, on a 'per site & general' basis.
    – Tetsujin
    Feb 5 '20 at 16:01
0

This solution will likely help you to get what you are looking for it.

  1. Go to your user name under /Macintosh HD/ Users/XXXX

  2. Right-click on your username and click on Get Info

  3. Under the section “Sharing & Permissions”, unlock the lock from the lower right and enter the password.

  4. Apply to enclosed items -> Click OK for the pop-up windows (Applying Permissions)

enter image description here

  1. Reboot your device and try again. It should pop up after that.
1
0

Seems like something related to TCC. If you want to reset the permissions, you can open terminal and run "tccutil reset All"

which will reset all the privacy access for your apps.

You can also run tccutil reset Microphone if you just want to reset microphone access.

More details can be found here

Hope this helps!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .