12

Since I have osxfuse installed it would be nice if I could use it. There are a lot of (heavily) outdated articles here, saying that it is not possible. Is this still the case?

2
  • 3
    I use Ubuntu in a virtual machine on my 2011 iMac. So accessing is a EXT4 disk is trivial for me. I start Ubuntu, mount the EXT4 disk, then share the disk with macOS. Both VirtualBox and Ubuntu are free products. I suppose the downside is this costs about 22 GB of space on my macOS volume for Ubuntu. Feb 4, 2020 at 11:26
  • I agree with @DavidAnderson - lots of options here to read and write to EXT4 despite no native support in a stable and cost-efficient method.
    – bmike
    Sep 22, 2020 at 11:42

4 Answers 4

12

Mac does not support Ext4 file system. If you plug in a hard drive, Mac won't recognize it. Fortunately, there are several ways to handle this situation.

1. Temporary options: Use VM

Just install a version of Ubuntu, or whatever your Linux distribution of choice is, in a virtual machine host like VirtualBox, then mount the drive as you would any other and read away.

2. Add Ext4 support for macOS

If you regularly use Ext4 formatted drives and / or need to copy multiple files from there to the macOS drive, you need a better option.

You need to install some software, namely macFUSE (replaced osxfuse) and ext4fuse. The easiest way to install ext4fuse is to use Homebrew.

First, download and install macFUSE from their releases page or install it using Homebrew.

brew install --cask macfuse

Then use Homebrew to install ext4fuse.

brew install ext4fuse

After installing the Ext4 support software, you now need to determine the hard drive you want to mount. To do this, run the following command:

diskutil list 

Save the partition ID (will look like /dev/disk3s1). Then, run the following command to mount the hard drive:

sudo ext4fuse /dev/disk3s1 ~/tmp/ext4_support_PARTITION -o allow_other

ext4_support above can be any name you choose. Now, navigate to the '/ tmp /' directory in the Finder and you will see the contents of the partition listed. If your drive has multiple partitions, you can mount them using the same steps as above. Just make sure to use different directory names to mount them.

Update

Attempting to install ext4fuse with brew results in an error. (See issue #66 on GitHub), so instead use the following commands to install it:

curl -s -o ext4fuse.rb https://gist.githubusercontent.com/n-stone/413e407c8fd73683e7e926e10e27dd4e/raw/12b463eb0be3421bdda5db8ef967bfafbaa915c5/ext4fuse.rb
brew install --formula --build-from-source ./ext4fuse.rb
rm ./ext4fuse.rb

Warning

Although these tools can help you read Ext4 formatted hard drives, they are not stable. As long as you are mounting read-only drives, as what is being done in this solution, you will not have many risks. If you try to use these tools to write to an Ext4 drive, you may lose data.

If you need to move files back and forth on a shared drive with Linux, this method is not recommended. Instead, use another file system like ExFAT or try the commercial option listed below

3. Use Paid Software

Software such as Paragon offers a free trial version, but to be safe, you should back up your hard drive first, in case there is a problem. If you want to buy software, it is available for 40$ Note: I haven't used this tool and can't say anything about what they have promised.

Although reading Ext4 format on macOS is no longer an impossible task, it is frustrating when Apple does not support this format.

Try it on your own risk but I strongly recommend the first solution which is easy and convenient.

5
  • 1
    I got an error: Error: ext4fuse has been disabled because it requires closed-source macFUSE! What did I do wrong?
    – ywiyogo
    Aug 8, 2021 at 19:57
  • 2
    @ywiyogo : Unfortunately you did nothing wrong. ext4fuse has been removed from homebrew due to changes in the license. Read more here: github.com/Homebrew/homebrew-core/pull/64491 . However, can install everything manually: github.com/osxfuse/osxfuse/wiki/Ext
    – thorsten
    Aug 17, 2021 at 20:23
  • 1
    It looks like that this answer is adopted from here. If it is the case, it would be nice to refer to this source in your answer.
    – cartoonist
    Aug 20, 2021 at 17:03
  • From this answer, it is unclear if I should install macfuse and then ext4fuse, or if macfuse replaces ext4fuse.
    – P A N
    Nov 6, 2021 at 9:39
  • Using a temporary VM did the trick and keeps OS X clean. Nice solution.
    – lilalinux
    Feb 23 at 20:37
9

For newer macs, e.g. Catalina, brew install macfuse instead of brew install osxfuse will work

2
  • 1
    This should be included in the correct answer.
    – ohaleck
    May 30, 2021 at 12:00
  • 1
    what is the command of macfuse ? Tried both macfuse and ext4fuse but none worked Oct 15, 2021 at 0:10
1

With regards to the prior answer by @Udhy only the VM option has any chance of working but with a major caveat that it is VERY slow (I never got better than 30mb/sec).

Paragon simply does not work, refuses to mount any of my EXT4 disks. Not sure why, maybe a Catalina issue? However I'm not going to pay them so they can tell me we're SOL.

ext4fuse is a waste of time, it has not supported the last 3 versions of OSX so unless you're pre-Sierra this is not an option. There's an open issue in the Github: https://github.com/gerard/ext4fuse/issues/36

It's five year's old and his last reply was 3 years ago, so don't get your hopes up.

1

The only way I have been able to read/write ext4 is by using a virtual machine such as Virtual Box, running Linux (e.g., Linuxmint). It's odd that Paragon doesn't work in Catalina. Ext4fuse only gave me errors.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .