Cannot open the App Store, after upgrading to macOS Catalina 10.15.3.

Things I have tried:

  • We’ve had some people report the same issue. Might you have an update?
    – bmike
    Apr 12, 2020 at 22:25

3 Answers 3


What I have done is delete the App Store key chain entry in Finder, Application, Utilities, Keychain Access and the search for appstore. Delete just that one. (MacOS Catalina)

  • There is no such entry in keychain, may be I have already deleted it. But still the problem remains. Mar 26, 2020 at 8:54
  • Perhaps you can try to delete all the temporary files and start in safe mode to open the App Store. If the problem persist I would try to reinstall Catalina.
    – Ignacio
    Mar 26, 2020 at 10:13

After trying every other step, including reinstalling the catalina os from recovery mode

Only this worked for me

keychainaccess -> preferences-> clicking on "reset my Default key chain" -> reboot machine worked as stated here

Note: you will loose all the saved passwords

  • Seems a bit drastic. Anyone tried opening the App Store in a brand new user account?
    – benwiggy
    Apr 21, 2020 at 9:04
  • I'm in IT and tried every other possible method to get the App Store working again after updating to Catalina (could not update/download/buy apps: it would just sit and spin the icon). I tried pruning the Keychain manually to no avail. As soon as I reset the Keychain and rebooted, the App Store started working properly again. Obviously there's a non-obvious entry that's hosed, but I couldn't find it. BTW, it's really not all that drastic, unless you use your Keychain to store tons of passwords; I use LastPass for that. Resetting also leaves a backup of the old one in ~/Library/Keychains/
    – JohnEDee
    Sep 27, 2020 at 16:23

Open Keychain Access and search for any entries matching "app store". I found one for the appstored process that once deleted, allowed the App Store to fire right up without even restarting the OS. Didn't get a screenshot unfortunately and it wasn't re-created.

If that works, you won't have to wipe out your entire default user keychain. If you have to go that route, make sure to take thorough backups of the .keychain or .keychain-db files first.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .