I have an iMac running Catalina (10.15.2) that I don't have a keyboard or mouse plugged into. I just want to use it via screen sharing and SSH.

The problem is that often when I want to use it I can't. SSH hangs, screen sharing won't connect. I've tried restarting it via the power button, but even when it gets to the login screen I can't use SSH or screen sharing.

The only thing that seems to work is plugging in a keyboard and mouse, and logging in the normal way. Then SSH and screen sharing start working. They continue to work for a while. Eventually I come back and it's back in a bad state.

In Energy Saver settings I checked "Prevent computer from sleeping" and "Wake for network access" as well as "Start up automatically after power failure", power nap and hard disk sleep are unchecked.

  • I can see this happening via Screen Sharing (it's VNC after all) but not via SSH. If you leave your mouse/keyboard plugged in, after the period of time this usually happens, can you log in then? What about a 3rd party offering like TeamViewer? Does this problem present with them as well?
    – Allan
    Commented Feb 3, 2020 at 18:51
  • I left it overnight without mouse and keyboard and I can still remote login. I suspect the issue is that it only doesn't work after restart. So the times it breaks are when it auto-updates or loses power.
    – Max
    Commented Feb 4, 2020 at 13:21
  • Do you manually start services when you restart? Try restarting. SSH has exactly zero to do with your mouse/keyboard
    – Allan
    Commented Feb 4, 2020 at 14:12
  • Obviously. The issue is that I have to log in manually before SSH works. I do not manually start the services, they seem to start on login, but I want them to be available on startup so that I don't have to plug in a mouse and keyboard to log in.
    – Max
    Commented Feb 4, 2020 at 14:21
  • Are you using the built in SSH or a 3rd party variant? Did you upgrade SSH from Homebrew or something?
    – Allan
    Commented Feb 4, 2020 at 14:23

1 Answer 1


This is caused by having FileVault enabled in the security settings. The disk won't decrypt until someone logs in, so services like remote desktop and sshd won't start until then.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .