0

Time Machine started failing on an external USB drive.

Time Machine couldn’t complete the backup to “ExternalTimeMachine”.

An error occurred while enabling ownership on the backup disk. You may need to repair or erase the disk using Disk Utility. If the disk can’t be repaired, select a different disk for backups.

Latest successful backup: January 26, 2020

I ran First Aid from Disk Utility and there are no problems.

I tried enabling ownership manually. The Ignore ownership on this volume option is missing for this Time Machine volume's Get Info in Finder whereas other volumes on the same physical drive have this option. I enabled ownership through the command line and Time Machine continues to have the same error.

$ sudo diskutil enableOwnership /dev/disk5
File system user/group ownership enabled
$ sudo diskutil enableOwnership disk5
File system user/group ownership enabled

Disk Utility reports the following:

Mac OS Extended (Journaled, Encrypted)
Type: CoreStorage Logical Volume
Owners: Enabled
Connection: USB
Device: disk5
  • This is the kind of task I would give to DiskWarrior – Tetsujin Feb 2 at 9:39
  • I don't think there is anything wrong with the volume. In this case I removed the backup from Time Machine and added it back immediately. It backed up fine. – apricot Feb 2 at 18:22
1

I removed the backup from Time Machine and added it back. It continued the backup successfully after that. Looks like yet another brittleness in Time Machine.

| improve this answer | |
  • The same problem returned on the next backup! – apricot Feb 2 at 21:43
1

I have just gone through 3 weeks of hell trying to workout why Time Machine was failing. After thinking I had solved the problem - purchased and formatted a brand new external hard drive, excluded my antivirus software, added the exception to Spotlight, ran a full deep anti-virus scan (nothing found) - I disabled everything (energy saver, screen saver, wifi, blue tooth, internet - I was able to complete a new initial back-up - 220GB. Note: it stalled and failed at 160GB, but I just restarted it and it recommenced indicating it only had 60GB to back-up (and took several hours to complete).

I found myself still having issues with the incrementals - they were still around 3GB and would take 40-50 minutes to complete (even though I had done no work on my computer). There were no error logs. Finally, I disabled Outlook for Mac and went to the web based interface.

Backups are working fine now, and the incrementals take 2 or 3 minutes and are about 120MB in size (depending on what work I am performing).

Since I transitioned to Outlook about 18 months ago (company requirement), it appears to have taken over my Macs resources both in CPU time and storage, and the complicated index and file structures it uses seem to cause issues with Time Machine.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .