1

I am trying to delete a TM backup on Mojave using sudo (this has worked in the past).

Any ideas why I'm now getting this error - apparently 4294967295 is a UID in the sudo command.

I get the same error trying to delete another backup in the list.

Snapshot of backups and delete attempt

sudo version:

Colins-MacBook-Air:~ Colin$ sudo -V
Sudo version 1.8.29
Sudoers policy plugin version 1.8.29
Sudoers file grammar version 46
Sudoers I/O plugin version 1.8.29
9
  • Thanks. I just checked - all up-to-date. No pending updates for Mojave. I tried other sudo commands - eg, "sudo ls" - same error, but "sudo -V" worked ok.
    – Colin
    Feb 1, 2020 at 8:15
  • I don't have an answer to the problem, but a work around would be to use sudo su to get root and then run the command. Feb 1, 2020 at 12:49
  • Unfortunately, when I try "sudo su", I get the same "sudo: 4294967295: invalid value" message :-(
    – Colin
    Feb 1, 2020 at 13:56
  • Try running sudo visudo and see if the file shows and if it is corrupted in anyway. Feb 1, 2020 at 14:16
  • :-( Same error: sudo: 4294967295: invalid value
    – Colin
    Feb 2, 2020 at 8:45

0

You must log in to answer this question.

Browse other questions tagged .