1

My MacBook Pro early 2011 developed the same problem many people have: it stopped starting up. Trying to follow the instructions in this post: GPU problem - Boot Hangs on Grey Screen and partly this: Single-User-Recovery-Mode on High Sierra 10.13.6, especially Luca Bonavita's suggestion, I got stuck when I tried to create the Extensions-off folder. My MBP has a partitioned hard drive. When I start up in single user mode, it addresses the "first" partition, which runs on Mountain Lion, so the Extensions-off folder was created on that partition. However, ML does not not have the offending AMDRadeonX3000.kext file, so I ended up with: No such file or directory when trying to move the kext. I tried to access the other partition that runs El Capitan via target mode with the below code, but could not even get past the first step.

cd /Volumes/Yosemite

(Yosemite being the partition that runs El Capitan)

mkdir -p /Yosemite/System/Library/Extensions-off

I assume the csrutil disable command is necessary afterall? If so, how can I use that on the second partition? Or is it the /sbin/mount -uw /that was missing? Or did I just make a mistake in the code (basically just copying and pasting, as the noobe that I am...)?

Edit: The code was wrong; it should've started with sudo and then /Volumes:

sudo mkdir -p /Volumes/Yosemite/System/Library/Extensions-off

The System integrity is OFF on the ML (first) partition. Edit: Apparently, ML does not have SIP, hence DiskUtility on the iMac showed OFF for that volume.

I followed the instructions for Sierra, because I was not able to boot into single user recovery mode.

14
  • ML doesn't have SIP at all; it doesn't know what it is. You can only disable SIP from a Recovery partition that does know what it is. Additionally, is there a good reason a Mac perfectly capable of running High Sierra still needs to run ML & El Cap? – Tetsujin Jan 31 '20 at 18:03
  • When I ran that command in Terminal, I got the following repsonse: 'Successfully disabled System Integrity Protection. Today I ran DiskUtility on my iMac (also running El Capitan) with the MBP as target and found: "System Integrity Protection enabled: No" for the first partition and "Yes" for the second, El Capitan, partition. The first, ML, partition was just a left over from when I tested my old Adobe software on El Capitan. – Coxy92 Jan 31 '20 at 18:29
  • Terminal test: csrutil status Result should be System Integrity Protection status: disabled. [or enabled] or command not found It can only be toggled from a recovery partition that knows what it is. – Tetsujin Jan 31 '20 at 18:33
  • Is there a way to do that in target mode from the iMac, addressing the important El Capitan partition? –– I ran it in recovery mode and now it tells me: 'System Integrity Protection status: enabled (Apple Internal).' – Coxy92 Jan 31 '20 at 18:58
  • 1
    I can't exactly follow your steps. (Eg after creating a folder it is no wonder to me that there are no kexts in there?) Please provide more details for each step taken and perhaps the structure of your partitions? It reads to me as if you try to issue commands that touch paths in an environment where the target of that command isn't mounted? (Plus as per klanomath's observation the path starting /Yosemite…will work nowhere) – LаngLаngС Jan 31 '20 at 19:26

You must log in to answer this question.

Browse other questions tagged .