0

MBP 13" 2017 - Catalina - 10.15

The time is annoyingly off by ~2 minutes 55 seconds. I've confirmed with other iPhone users and the time on our phones are the same, it's just that MY Macbook time is slow.

This is a computer for work so it's irritating to get notifications for each meeting at different times on MBP and iPhone. Interestingly, when I receive messages on Slack, the timestamp is ahead of my system time.

Time Zone is correct both manually and when I select the "set time zone automatically" option.

When I use the ”Set date and time automatically” the time doesn't actually change. The time uses "Apple Americas (time.apple.com)

Querying the time server directly results with the following info:

enter image description here

I then went to time.is and see the following discrepancy:

enter image description here

17
  • 1
    In an attempt to reduce latency, your iPhone may be fetching the time from the nearest cell towers rather than via the internet. This is especially true if your iPhone is not connected to WiFi. In any case, the discrepancy should not be more than a few seconds. — Can you confirm that, on your Mac, in Date & Time preferences, "Set date and time automatically" is checked and an Apple time server is selected, e.g. time.apple.com?
    – Jivan Pal
    Jan 24 '20 at 20:04
  • 1
    You can query the time server directly via the terminal with e.g. sntp -d time.apple.com to see what time the clock should be set to. Unfortunately, you cannot easily do these checks on your iPhone, nor can you choose or enforce the use of a specific time server.
    – Jivan Pal
    Jan 24 '20 at 20:04
  • @JivanPal I've updated the question with the information you've provided. Do you see any issues in the time query?
    – Rob T
    Jan 24 '20 at 21:00
  • Nope, the system time is in sync with the time reported by the server (14:54 Central Standard Time), so the issue must be with your phone, as I previously described. There's not much you can really do except to try and force the iPhone to get the time over the internet. You can try this by connecting to WiFi and removing the SIM card; or turning on Airplane mode, then turning on WiFi. Then restart the device with this configuration and see if it re-syncs the time. Even if this works, I wouldn't be surprised if it goes back out of sync later, though.
    – Jivan Pal
    Jan 24 '20 at 22:00
  • 1
    @RobT, I apologise, the figure +138.201493 in the Terminal screenshot shows that you are 138 seconds slow. To sync your system time, run sudo sntp -Ssd time.apple.com. It is strange that checking the box in Date & Time preferences does not automatically sync the time for you, though.
    – Jivan Pal
    Jan 27 '20 at 21:12

You must log in to answer this question.

Browse other questions tagged .