0

I have a weird problem with the Music app on Catalina. When I want to play a playlist, sometimes it only plays one song and then it stops. The "Up Next" list has other songs listed but the app doesn't play anything, and even when I press play still doesn't play anything. It somehow gets stuck. Sometimes when I play with the Repeat button it gets fixed temporarily but then it comes back again after a while. This is a new issue I have after upgrading to Catalina. Any ideas?

1

Try this, which worked for my colleague while he also had a similar kind of issue after upgrading macOS to Catalina:

  1. Move your music out of the Music folder and delete everything left in it.

  2. go to ~/Library and remove any folders that have Music or iTunes in the name

  3. go to ~/Library/Caches and delete any folders with Music or iTunes in the name

  4. Reboot

  5. Put your music folders back where you had them before. You may need to Import your music again to let the Music app organize them in a way that makes sense to it

After doing this, it should fix your issue.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .