1

My 2012 Mac Mini is running High Sierra, and I have copied older mail folders to a partition of an external drive. In the User mail folder, I then placed symlinks. In Finder, the symlinks show the complete hierarchical contents of the folders; but, while the Mail program sees all of the folder structure, it does not display the messages within. Any clues will be appreciated!
Edit 01/28 – Permissions look Ok; wonder about "Sandbox" – can't seem to find about that.
I found these similar questions, also relevant, but older OS versions: Moving individual Mailbox to external drive and How to move all of my mails to external HD and make them appear only when its connected and
Transferring Emails saved on Mac to generic folder and
https://discussions.apple.com/thread/7001081

2/2/2020 - Ideas, anyone?

  • Are you sure that you created real symlinks via ln -s, rather than creating aliases via the "Make Alias" option in Finder? You can check this with ls -l on the terminal. A symlink will show e.g. test-symlink.txt -> test.txt, whereas an alias will not. Instead, aliases have an extended attribute, indicated by the @ that follows its permission list, e.g. -rw-r--r--@. – Jivan Pal Jan 24 at 20:28
  • Thank you for the suggestion. Yes, the symlink (both the one created on the external drive, and the copy placed in the Mail folder) has no"@" on the permissions. And a separate alias on the external does have that. I used the Mac application SymbolicLinker2.1.1 by Nick Zitzmann the create the symlink. – user2407486 Jan 25 at 23:02
  • Here are the results of doing "ls -l" – the permissions show drwxr-xr-x@ on the External mail archive folder, and lrwxr-xr-x on the symlink for it, and -rw-r--r--@ on an alias for it; whereas normal Mail folders look like drwxr-xr-x@ [and drwxr-xr-x+]. Thus, yes, something wrong with the permissions ... – user2407486 Jan 25 at 23:11
1

Wow, I just discovered that while this would not work in High Sierra, it does work in Mojave!
And then as I did some further importing, it no longer worked ... sigh ...

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .