6

I attached a brand new Seagate USB SSD drive (Backup Plus Slim) to a MacBook Pro running 10.15.2. It mounted the first time, I could see it in Finder, and was able to run the Mac start up program on the drive. However this did not seem to work, so I disconnected the drive. I thought I ejected it properly but not absolutely sure.

Then when I plugged it in again, I could not see it in Finder. I also tried on a Mac mini running 10.14.6 but could not see it in Finder either. Back on the MacBook Pro, I tried Disk Utility. It found the disk, but it was greyed out and not mounted. When I tried to mount it, I saw the following error:

Could not mount “disk2s2”. (com.apple.DiskManagement.disenter error -119930868.)

Doing a search on Google, I found this discussion, which indicates it is a Catalina problem. I could not see any useful answer.

I have tried waiting for hours for it to fix itself and rebooting my machine, but it appears that the disk has become damaged. How do I fix this?

3
  • Have you tried to reformat it in disk utility? Jan 23 '20 at 7:03
  • Erasing the disk worked, thank you. However, from the discussion group I have cited a lot of people had the same problem but with a disk that had data on it. Do you want to turn your comment into an answer so I can accept it?
    – Obromios
    Jan 23 '20 at 8:51
  • Erasing the disk is not a solution to the problem, but rather a not handy workaround when you already have the data on the disk May 30 '20 at 8:50
1

Exactly my issue, but luckily, the solution was simple! Take a coffee and wait. Seems like Catalina does a thorough disk check whenever you try to mount some sort of disk. For example, my HDD had around 500GB of data and it took around 5 minutes before it was automatically mounted and working as expected. In the meantime, I was unable to mount and to eject the disk (the error was the same, the disk was in use by another process). Simply plug in the disk and let the OS do the check it needs (some other users might know more about what is going on in the background and feel free to edit my comment to extend the knowledge). Patience, it will mount itself automatically after it finished all the background checks :)

1
  • 1
    Hmm... I don't know. The OP mentioned he/she had waited for hours on end to no avail, and this was with an empty SSD, whereas your hard drive with 500GB of data mounted itself in 5 minutes. I think they may be different issues, with similar symptoms. But then again, you may be entirely correct and the drive may have mounted after waiting even longer. ¯\_(ツ)_/¯ May 30 '20 at 14:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .