The attached image is what's currently displayed if I click on the wheel in Finder. Is it related to 'bird' and if so how?

enter image description here

But does anyone know what causes this to happen?

OK. Thanks to another post, I'm on the trail of the culprits.

robert@zeus brctl-dump % brctl monitor com.apple.CloudDocs|grep % 
 o /com~apple~CloudDocs/Downloads/badaboombb_ot/fontinfo.txt ↑ 2 KB (1834) 95.0% 
 o /com~apple~CloudDocs/Downloads/backissuesbb_ot/fontinfo.txt ↑ 2 KB (1834) 95.0% 
 o /com~apple~CloudDocs/Downloads/Afans Live Filters - for Designer 1.6.zip ↑ 92 KB (91525) 95.0% 

And so on for a maybe hundred files in my case. All files show the little UP arrow, indicting that uploading is still taking place, and the percentage left at the end of the file info. All of them 95% SO it seems to be getting stuck at 95%? Also, some of the files listed no longer exist. I've long since deleted them, yet here they are still in the upload list. What to do.

I found this useful info in another post here. View amount of time left when uploading files to iCloud

======== Progress of sorts ========

In all this - Photos is syncing perfectly. Anything from any of my devices, iPhone and iPad is syncing perfectly. It's just this Mac that seems to be stuck.

Doing a 'log show | grep Cloud streams a LOT of information about what's happening. And this looks interesting, and there is a lot of it repeating. Does this indicate something is Stuck and throttling iCloud?

2020-01-22 13:18:20.328917+0000 0x459b     Error       0x807e               469    14   bird: (CloudDocsDaemon) [com.apple.clouddocs:default] [ERROR] Failed to remove sync root bit [22: Invalid argument]
2020-01-22 13:18:20.329095+0000 0x459b     Error       0x807f               469    14   bird: (CloudDocsDaemon) [com.apple.clouddocs:default] [ERROR] Failed to remove sync root bit [22: Invalid argument]
2020-01-22 13:18:20.329174+0000 0x459b     Error       0xbc20               469    14   bird: (CloudDocsDaemon) [com.apple.clouddocs:default] [ERROR] renameat(-1, '<private>', 21, '<private>', 4) failed after trying to fix permissions [17: File exists]
2020-01-22 13:18:20.329313+0000 0x459b     Error       0xbc21               469    14   bird: (CloudDocsDaemon) [com.apple.clouddocs:default] [ERROR] -[BRCStageRegistry moveFromStage:toPath:fileName:error:]: (passed to caller) error: Error Domain=NSPOSIXErrorDomain Code=17 UserInfo={NSDescription=<private>}
2020-01-22 13:18:20.329422+0000 0x459b     Fault       0xbc22               469    14   bird: (CloudDocsDaemon) [com.apple.clouddocs:default] [CRIT] UNREACHABLE: Failed to move from fault stage to live Error Domain=NSPOSIXErrorDomain Code=17 UserInfo={NSDescription=<private>}
  • No further progress. iCloud Drive will not upload to iCloud. Everything that appears to be queued is stuck at 95%. No new directories are created. No files transferred. bird is busy doing whatever bird does, and "brctl monitor com.apple.CloudDocs|grep %" returns a huge list of docs waiting to upload. As mentioned. How do I unstick them to progress pas 95%? No idea yet. Jan 28, 2020 at 9:39
  • A little progress. I can manage files I no longer want on the Mac, with the new option in Finder to Remove Download. Effectively 'brctl evict' ... ok, that's good. But I still can't find a way to find out what files are waiting to upload, and why they arent. Downloads I can do, uploads don't do. So I need a force upload somehow. Jan 28, 2020 at 16:37
  • 1
    This question was already answered here, I was facing the same issue, and the answer provided there by user9869932 worked for me.
    – Yazeed
    Jan 20, 2021 at 17:45
  • Thanks @Yazeed for the links and confirmation
    – bmike
    Jan 20, 2021 at 18:53

1 Answer 1


First, have you tried the suggestions in this thread: https://discussions.apple.com/thread/251061918

I have tried all the things that Apple support pages suggest, such as force-quitting Finder, rebooting, rebooting into Safe Mode, all to no avail.

If those don't work, I suggest you contact Apple Support directly on this one. I am working with them on what I believe is an identical issue of iCloud files not syncing from my Mac (macOS Catalina) to iCloud since the last few days.

Go to https://support.apple.com/icloud and scroll to the bottom and click on the "Get support" link and choose "Update, Backup, and Restore".

I have spent perhaps 3 hours with 3 different support people as the issue gets escalated to the support engineers.

I don't know about you, but some files do sync up and back just fine, like those associated in iCloud Drive with certain applications (eg, Drafts, MindNode). I can create a text file at the top level of iCloud Drive and it syncs. But not for folder that I create manually.

I have gone through a macOS Catalina re-install (via Recovery Mode) and that did not solve my problem. I am now awaiting the support engineers to review diagnostics information from my computer. When I have a definitive answer, I will report back on what hopefully solves my issue.

I had wanted to comment on your post, rather than answer it, but I don't have sufficient reputation points to do that.

Cheers, David

  • David, thanks for the detail. I gave tried just about everything you have, including talking to Apple engineers. All to no avail. I have also noticed that the syncing doesn't want to create new folders up on the iCloud server. I can create a folder on my computer where iCloud can find it, but it doesn't replicate on iCloud.com. Jan 26, 2020 at 20:35
  • 1
    I've tracked down "brctl" which you can use to monitor/investigate iCloud and bird and so on. Do a 'man brctl' - no I add that I'm not much wiser, but and finally getting down to a level where I can see what's going on. 'brctl monitor' eventually starts and returns a whole slew of info. It took quite a few minutes before it picked up what what haappening though. I suspect a timer behind it? Jan 27, 2020 at 14:43
  • I found some other threads that involve killing the bird processes, killing all the bird processes, deleting the CloudDocs directory and database, and immediately restarting (eg, apple.stackexchange.com/questions/313716/…). I haven't had the courage to do that yet. Jan 27, 2020 at 15:53
  • But if you do, make sure to back up the stuff on your Mac in the iCloud directories that you consider to be "true" data, just in case restoring the iCloud directories pollutes your Mac with the old data. Reading some of those threads, they seem to advocate for cleaning directories on iCloud.com to remove as much of the stuff you don't want as possible. Jan 27, 2020 at 15:54
  • I"m beginning to suspect that Uploading is outrageously slow - and that that is one of the problems. There are other problems as well, but I"m sure that's one of them I'm also running iCloudStatus as well, which shows uploads, but is also a bit flakey I think. Jan 28, 2020 at 9:48

Not the answer you're looking for? Browse other questions tagged .