1

I have an iMac (always newest OS which now is Catalina) with a big monitor and a second external monitor, i.e. I have two big monitors on my desk.

In the settings of Mission Control I have chosen that my monitors shall NOT use different spaces. (I want to spread spreadsheets and other apps across both monitors to have a wide view on them, this is only possible when both monitors share the same space).

My version of Microsoft Remote Desktop is 10.3.7 which also is the newest version. Everything works fine, but MRD always starts in full screen mode. This means it covers one screen entirely while the other screen completely turns into black. But I want to see my mac Desktop on the other screen, because I sometimes want to drag and drop files between the two systems (which btw. works perfect).

I always have to switch MRD into windows mode and then have to drag this windows corners until the window covers one of my two monitors, and the I can work in both systems.

But It would be much more convenient if MRD would already start in windows mode instead of full screen mode. But I didn't find a matching switch in the settings.

How can I tell Microsoft Remote Desktop to always open in windows mode on my mac?

btw: I don't need full screen mode on my Mac for any app. So, I also would be very happy if there was a way to disable full screen mode on my Mac completely for all apps.

2

Check the display settings - right click your saved session & Edit or click the small pencil icon bottom right of it…

enter image description here

I don't recall what the defaults are - I've had this set up too long to remember - but the above settings work well for me, to open maximised* but not fullscreen on my second monitor, which I have set as you do, not using separate spaces.

*or rather 'the same as I last used it'.

| improve this answer | |
  • This looks very different in my version (Version 10.3.7 (1733)). When I click on the gear icon a drop down menu appears showing "Pin to Menu Bar", "Preferences...", "Help", "Import open RDP file..." and "Quit". When I choose "Preferences..." from this menu, a new window titled "preferences" pops up with 5 tabs: "General", "User Accounts", "Gateways", "Groups", "Resolutions". None of them has settings for full screen mode. This preferences window is identical to the window that I get when I choose "Preferences..." from the menu bar on top of the screen. – Hubert Schölnast Jan 22 at 9:02
  • The beta & release versions are currently in sync recently at build 1733, so we're on the exact same build. You don't need the overall prefs, you need the prefs for each specific saved remote machine… right click or click the pencil, not the gear icon [although Edit is also in the gear IF you already have a remote selected.] – Tetsujin Jan 22 at 9:09
  • Ok, it works. But this is not the place where I expect to find such preferences. I would like to have them in the preferences. Please, can you edit your answer to make clear where to find this setting? Because at the moment the real answer to my question just exists in your comment, not in the answer itself. – Hubert Schölnast Jan 22 at 18:39
  • It's right there, there's only one line of instructions… 'right click your saved session…' As the setting is per session, having it as a global pref wouldn't make much sense. I've removed 'in prefs'. – Tetsujin Jan 23 at 8:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .