0

I am trying to install Rstudio Server in Mac mini running on macOS Mojave. I followed this link to build Rstudio server from the source. I also looked at this link. I could successfully install it with no problems. But I get this error:

$ cd /usr/local/lib/rstudio-server/bin
$ rserver --server-daemonize=0  --auth-minimum-user-id=500 
rserver: command not found

I have the .plist and everything in the right place (needed to run rstudio server in the backend) but I don't get why does it say rserver command not found? I can provide any other detail if needed.

  • 1
    1. rserver is not in the PATH 2. check with ls (or another tool) if rserver is in /usr/local/lib/rstudio-server/bin/. 3. If true use ./rserver --server-daemonize=0 --auth-minimum-user-id=500! 4. Else: check whether rserver is somewhere else (e.g. /usr/local/opt/.... – klanomath Jan 22 at 1:16
  • @klanomath thanks! rserver is in my path in that directory. Okay, so I see that it has to be executed. It wasn't clear from the documents I was reading like github.com/randy3k/homebrew-r/issues/34 where it was talking about how to test the server. But, I am now getting a new error "[rserver] ERROR system error 13 (Permission denied) [description: Failed to get user details., user-value: ]". Not related to this question, I understand. Any clue? -- thanks again. – Ghosh Jan 22 at 4:37
  • (With 1. [...] PATH I meant the system variable but not the path in that directory ;-)) Prepend sudo ? – klanomath Jan 22 at 8:44
  • I used sudo command as well but got the same error. – Ghosh Jan 23 at 23:10
  • I tried to install r/rserver and all dependencies with brew (I had to add some tap because the official brew doesn't provide rserver) but finally failed to launch it properly (some ssh lib problem). It will take some time to set up a VM and get this to work with MacPort. Did you execute the sudo cp /etc/pam.d/ftpd /etc/pam.d/rstudio step? Other sources use another pam.d/ file - I don't remember which one though. – klanomath Jan 23 at 23:28
1

When any Unix/MacOS/BSD resides on the current directory and this directory is not in your environment variable PATH, you must prefix it with ./ to have it executed.

According to you, the binary IS on the current direcoty, so the command line has to be:

./rserver --server-daemonize=0  --auth-minimum-user-id=500
| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .