28

Whenever I'm trying to close a file that has been changed, I get the save file dialog

save file dialog

I remember that the Don't Save button used to have focus, so I could press it using Spacebar, while pressing Enter would click on Save. But now on Lion, I'm unable to find a way to press the Don't Save using keyboard only, since Tab doesn't change focus to anything, and space doesn't work either.

This is the same for all file save dialogs in the system.
Is there any way I can press the Don't Save button using keyboard only?

1
  • You can also select them with ⌘⌫, or ⌘D in some applications.
    – Lri
    Sep 20, 2012 at 10:50

2 Answers 2

38

Go to...

  1. System Preferences→Keyboard→Keyboard Shortcuts
  2. and select All controls under Full Keyboard Access

    • Now you can use (tab) to switch between the dialog boxes.
    • Note: Unlike in Windows, you need to hit space to trigger a highlighted box that is not the default one! (If this is not natural to you, here's something that helps many to remember tab and space rather than just enter. The space bar is the keyboard version of a one button mouse with the tab moving the mouse's pointer for you.)

enter image description here

4
  • Unfortunately, this no longer works as of Mountain Lion (OS 10.8.0). Does anyone have an update? Aug 11, 2012 at 18:06
  • @TrevorBurnham It works for me on OSX 10.8.1. Sep 17, 2012 at 21:49
  • @TrevorBurnham You have to hit space if you want to trigger a selected button that is not the default one.
    – gentmatt
    Sep 20, 2012 at 9:07
  • I'm no longer experiencing the problem I reported above. Must have been fixed in 10.8.1. Sep 20, 2012 at 17:36
5

On version 10.15.6, the previous answer didn't work as is.

If you want to switch with Tab or "don't save" directly with the Space key, you'll need to go to System PreferencesKeyboard and toggle this option:

printscreen of the toggled option

1
  • 2
    I want to confirm this solution works for me. Thanks for sharing your experience!
    – Tung
    Feb 18, 2021 at 12:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .