There is a yellow tooltip stuck and it floats above all other windows. I do not know from what program it came.

How can I get rid of it without restarting my computer?


Offending tooltip

  • what does the tooltip say or can you post an image?
    – Stu Wilson
    Commented Jan 23, 2012 at 14:48
  • @StuWilson: Done! Should have included it from the beginning... :)
    – benregn
    Commented Jan 23, 2012 at 14:51

7 Answers 7


There is a way to find out what application is responsible, if you have the developer tools installed.

In versions of Mac OS X before 10.6, the Quartz Debug tool had a Window List which lists every window and the application it belongs to. Unfortunately, this has been hidden in later versions, but it can be enabled (as I just found through this article: 10.6: Quartz Debug 4.0 Secrets) — run the shell command

defaults write com.apple.QuartzDebug QDVisibleClientIdentifiers -array-add -string QDWindowInfoClient

and then launch Quartz Debug. You will be able to browse all the windows and see images of each, push the “Reveal“ button to highlight it, or look at the heights to find windows that are of the right size.

This setting takes effect until you close the window. The linked article has suggestions for permanently enabling a way to bring up that window, but they don't seem to work on my Lion system and I haven't found any newer discussion. This rather suggests Apple thinks these tools shouldn't be readily accessible, so play with this at your own risk...


The simplest way to get rid of this, at least when it happens for me, is to hover over anything with a tooltip to get a new tooltip. Happens to me quite often with Safari these days, very annoying.

  • 1
    Amazing that this bug was reported in 2011 and here we are 4 years later with people still reporting it.
    – Fixee
    Commented Aug 13, 2015 at 19:59
  • 1
    I just tried hovering over something else, which indeed displayed a tooltip ... but the original annoying tooltip is still there. This is on "El Capitan", OS X 10.11.1.
    – offby1
    Commented Nov 12, 2015 at 19:38
  • @offby1: That's something I've never seen before - except with some (rare) applications/games that have their own tooltip programmed, rather than using the "built-in" OS X tooltips. These usually look a bit different. But if this is a normal tooltip, then I guess it's a new bug, or at least a new form of the same old :/
    – Ilmari
    Commented Nov 13, 2015 at 14:55
  • I am interested; how many of the people experiencing this problem are running Sublime Text?
    – Ilmari
    Commented Sep 1, 2016 at 15:06
  • 1
    You have to find the right app that generated the stuck text, and hover over anything with a tooltip within the same app.
    – jellycsc
    Commented Aug 31, 2021 at 17:19

You can often make it go away just by quitting the application. If that doesn't solve it, you may have to use ++esc to relaunch the Finder.

  • 7
    I would do that, but I just don't know what program spawned it.
    – benregn
    Commented Jan 23, 2012 at 14:47

The way I solved it was to log out and in again. Not the ideal solution but I guess that when you don't know what program it belonged to, there aren't many options.


I tracked this down at long last. See here for a workaround: https://gitlab.com/gnachman/iterm2/issues/4666

  1. Find out which window is responsible for it by hiding the windows individually (with +esc). When you hide that window, the info box also disappears.
  2. Reopen the window and hover the mouse over another area that generates a tooltip.

The program was "Eclipse" according to the theme named "Solarized Dark" - so java issue then :P

or iTerm uses the same theme.

  • Actually don't have Eclipse installed at all. I'm using the Solarized theme in pretty much all places that support color themes, e.g. Terminal and Sublime Text 2.
    – benregn
    Commented Jan 23, 2012 at 14:58
  • oh well, that doesn't help then in any way to differentiate which program was causing the issue since it's probably the same theme set loaded across different programs. There woudl have been no way then to find out which program caused the issue without closing each program program individually or en masse whcih was what you did when you logged out.
    – Stu Wilson
    Commented Jan 23, 2012 at 15:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .