2

My Late 2013 Retina MBP is shutting down randomly. It gets a blank screen, and the keyboard is lit up for about 10 seconds, and then it powers down. There is no kernel panic, and nothing in the logs shows a shutdown. It reboots fine, and generally works for several hours before booting again.

When running the AST OS tests, I get the following errors:

[01/16/20 17:24:31] AirPort (test #9) - Wireless Module PCIe Root Port Hardware Register Test
- Verifies PCIe root port error bits for wireless module doesn't register any NAKs
[17:24:32]  ERROR - -12100 [IOConnect error reading from PCI address space] -- TEST FAILED
[01/16/20 17:24:32] SATA - 0: SATA PCI Register Test (test #1) - SATA PCI Register Test
- Checks the SATA link error registers for dropped data packets using direct PCI access.
[17:24:32]  ERROR - -12105 [PCI driver IOService open error] -- TEST FAILED

I tried a number of things, but nothing worked:

  • applied new thermal paste
  • re-seated the cable from main board to i/o board
  • re-seated video
  • put in another SSD drive known to be working
  • wiped drive and reinstalled Catalina (didn't restore)
  • reset SMC and NVRAM

The machine has dual graphics, but disabling discrete graphics doesn't help.

Any ideas on what I can try next, and what the AST test messages mean?

1

You have a hardware issue.

There are two errors:

  • ERROR - -12100 [IOConnect error reading from PCI address space] -- TEST FAILED
  • ERROR - -12105 [PCI driver IOService open error] -- TEST FAILED

Both have to do with I/O (input/output) operations on the PCI bus.

  • The first, related to the AirPort card says that it can't read from the "PCI address space." The address space is a location in memory that points to a physical piece of hardware. When attempting to read from it, it errors out.

  • The second, is another I/O error, this time when attempting to connect directly to the SATA hardware; it received an error when trying to open it for operations.

Given that both of these errors related to entirely different pieces of hardware, but both are related in that it's happening on the PCI bus, you have a hardware issue on the logic board.

Bottom line: The logic board needs to be replaced.

| improve this answer | |
  • I tried some different power settings that have improved it - not sure if it has fixed it, but it has been running many times longer than before. I used pmset -a with the following settings: standby 0 powernap 0 sleep 0 hibernatemode 0 autopoweroff 0 displaysleep 0 – slarty Jan 19 at 7:10
  • You have a failing component, not failed. This means it you will see it work and then not. Power settings are pure coincidence. Plus, think about it...how much sense does it make that to properly operate your computer, you have to write some power settings that disable everything? What if you wanted hibernation? Outta luck? Something is wrong physically with your Mac; this is not a fix – Allan Jan 19 at 14:27
  • After a while it started crashing again. I took it in to a repair shop, and they had a utility (NoCrashMBP) that stops the crashing by preventing the voltage from going too low. It works, but they're going to replace the voltage regulators, which should fix it. – slarty Jan 27 at 17:41
  • That sounds extremely sketchy to me. 1) There's no software that can change the flow of electricity in that manner. None of the components on the logic board are software configurable especially when you have failing components. 2) What voltage regulator? That would be in your power brick. – Allan Jan 27 at 20:40
  • It's working perfectly now. The software fix was realmacmods.com/product/macbook-pro-nocrash-utility. It prevents the cpu from going into the lowest power state. It worked as advertised, but didn't solve the root cause. The repair guy replaced three regulators, and now it works perfectly without any software changes. I'm talking about regulators on the logic board - nothing to do with the power source/brick. – slarty Feb 6 at 20:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .