0

I'm trying to update a MacBook Air from early 2014 that runs OS X Mavericks (desktop) to the latest macOS (Catalina). I downloaded the installer for macOS Catalina from the App Store and when going through it, it gets stuck at the following screen:

enter image description here

I click 'Install' and the color of that arrow icon turns from black to the grey you can see in the picture above. Then nothing happens. I waited for several hours (thinking it might be slow), but nothing ever happens.

I also restarted the machine several times and attempted this installation again and again, but I can't seem to get any further.

Any ideas of what else to try? I would prefer to keep the data that I have on the machine, so just updating the operating system, not doing a clean install. I did make a backup with TimeMachine before attempting to update.

  • 1
    I love Mavericks—Apple is just letting you know Mavericks is better! :P But real talk, try making a USB installer and using that. This will not result in a clean install unless you also format the boot drive in disk utility. – Wowfunhappy Jan 17 at 12:32
  • Thank you for the suggestion @Wowfunhappy! Just checking, you're referring to following this guide, right? support.apple.com/en-us/HT201372 – Alex Jan 17 at 13:00
2

The jump from Mavericks to Catalina may be too much of a leap. Try first upgrading to High Sierra. The website How to upgrade to macOS High Sierra has a link you can use to download the High Sierra upgrade. I suggest this because the installation of High Sierra will also upgrade the firmware to recognize and boot from APFS containers. While this is not a requirement for High Sierra, it is for Catalina.

|improve this answer|||||
  • Great suggestion, I have not thought of that! I'll try that and come back with an answer whether it worked or not! Thank you! – Alex Jan 17 at 17:09
  • Thanks a lot! It worked, upgrading to macOS High Sierra and then to Catalina! – Alex Jan 21 at 8:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .