1

So recently my MacBook Pro 2018 Touchbar (4 USB-C and Intel I5 Quadcore) has been having a really weird problem after waking up from Sleep. Every time I open the Lid and log in, the screen wakes up like normal and sometimes I can see new notifications from Firefox.

However, my Mouse and Keyboard stay completely unresponsive.

I see the mouse cursor, but it just won't move. CTRL + Arrow key also won't change screens. It's exactly as in this post here from 7 years ago and sadly no fix.

  • It occurs from only for a few seconds to up to 30 seconds sometimes.
  • It also happens always for at least a few seconds, no matter where I am or what state I closed the lid in.

What could remove or resolve these post sleep freezes?

1

UPDATE: The NVRAM reset ended up being only a temporary fix. The answer here was the real solution. The problem seems to either be with VM software or closing the lid with a VPN running (the latter was the problem for me). Disconnecting from the VPN before closing the lid fixed the problem.

Original post:

This is a bit late, but resetting the NVRAM seemed to work for me:

  1. Restart your laptop
  2. When the Apple logo comes on screen, press and hold option + command + P + R
  3. The logo should go away and come back after a few seconds, and hopefully that should be it!
1
  • Interestingly, NVRAM reset never worked for me as well, and I've been using ZeroTier ever since, BUT! its gone. I don't know when It happened, I don't know why it happened. Even before the update to MacOS 11 it was rare, and since the update its just gone! Even with VPN running 24/7. Hope your answer helps others tho, since it seems likely to be connected to the VPN (if i remember correctly, it could've turned up around the time I installed it!) Jan 24 at 0:48
1

In my case this was happening even without a VPN or VM in use, so the link above might not be relevant for everyone. After seeing some claims that this issue was related to the SMC, I found this page:

https://support.apple.com/en-us/HT201295

Following just the first hard-reset steps in that link worked for me:

  1. Shut down your Mac.
  2. Press and hold the power button for 10 seconds, then release the button.
  3. Wait a few seconds, then press the power button to turn on your Mac.

And I haven't had any issues since then (a couple months), with or without VPN.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .